Modify

Opened 3 years ago

Closed 5 months ago

Last modified 4 months ago

#9799 closed defect (fixed)

Don't check for unread messages while upload is in progress, as upload process is then broken.

Reported by: rickmastfan67 Owned by: team
Priority: major Milestone: 17.03
Component: Core Version: latest
Keywords: upload Cc:

Description

This is quite simple.

Last night, I was doing an upload to the OSM server. Everything was working fine till JOSM pinged the OSM server during the upload to see if I had any unread messages. Unfortunately, when that happened, it broke the upload process as JOSM then never was told my upload was finished and was hanging on the upload bar. Plus it then breaks your OSM file that you're working on as it doesn't get the IDs for the newly uploaded items and then causes conflicts in the file as each item is then duplicated.

So, please somehow set a flag that while an upload is happening, that JOSM is not allowed to check for new messages. It should wait till the upload is finished as said by the OSM server.

Thanks.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-03-09 02:35:21
Last Changed Author: Don-vip
Revision: 6903
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-03-08 23:41:18 +0100 (Sat, 08 Mar 2014)
Last Changed Rev: 6903

Identification: JOSM/1.5 (6903 en) Windows 7 64-Bit
Memory Usage: 222 MB / 1820 MB (165 MB allocated, but free)
Java version: 1.7.0_51, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
VM arguments: [-Xmx2048M]

Plugin: ImageryCache (30277)
Plugin: OpeningHoursEditor (30235)
Plugin: buildings_tools (30277)
Plugin: measurement (30277)
Plugin: mirrored_download (30197)
Plugin: notes (v0.9.2)
Plugin: osmarender (30277)
Plugin: reverter (30307)
Plugin: turnrestrictions (30307)
Plugin: undelete (30277)
Plugin: utilsplugin2 (30277)

Attachments (0)

Change History (4)

comment:2 Changed 3 years ago by rickmastfan67

Well, it seems that it was just a one time fluke that it broke an upload for me, as I saw another upload not get affected by this happening.

Still, JOSM should just wait till the upload is finished anyways. That way it will prevent this from happening, even when it was just a fluke.

comment:3 Changed 5 months ago by Don-vip

Milestone: 17.03

comment:4 Changed 5 months ago by Don-vip

Resolution: fixed
Status: newclosed

In 11686/josm:

fix #9799 - Don't check for unread messages while upload is in progress, as upload process is then broken

comment:5 Changed 4 months ago by Don-vip

Ticket #14037 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.