Modify

Opened 5 years ago

Closed 3 weeks ago

#8356 closed enhancement (duplicate)

Should not select all the text when the window gets focus

Reported by: naoliv Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

When working with two windows (JOSM and another program, for example) and using a window manager where the focus is controlled by the mouse, I see one annoying behavior.

The attached video can give a better idea of this:

  • I open the properties window to add a new key/value and start to type the value.
  • Move the mouse outside JOSM (to the PDF file).
  • Get the mouse back to JOSM and all the text inside the value is selected.
  • I then have to press End or click at the end to start typing again (otherwise I lose what I have already entered on the text box).

It shouldn't select all the text when JOSM get the focus. It should just stay where the cursor was originally.

Attachments (1)

josm-focus.ogv (1.2 MB) - added by naoliv 5 years ago.

Download all attachments as: .zip

Change History (3)

Changed 5 years ago by naoliv

Attachment: josm-focus.ogv added

comment:1 Changed 5 years ago by stoecker

This is a problem of the autocompletion boxes.

comment:2 Changed 3 weeks ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #13747.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.