Modify

Opened 6 years ago

Closed 3 months ago

#7483 closed defect (fixed)

Problem with updating plugins with existing /usr/share/josm/plugins

Reported by: skyper Owned by: team
Priority: major Milestone:
Component: Core Version: latest
Keywords: Plugin linux debian ubuntu Cc: dpaleino, sebastic

Description (last modified by skyper)

I think there is a problem with updating plugins.
I have the debian package josm-plugins installed. These plugins are installed under /usr/share/josm/plugins. Even before downloading the plugin list the first time I already have some plugins available (local).

  1. start josm
  2. download plugin list
  3. install cadastre plugin
  4. restart

Exception with package from stable

Using /usr/lib/jvm/java-6-openjdk/bin/java to execute josm.
Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2012-03-06 02:36:00
Last Changed Author: Don-vip
Revision: 5046
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2012-03-05 22:41:23 +0100 (Mon, 05 Mar 2012)
Last Changed Rev: 5046

lade Plugin 'cadastre-fr' (Version 22295)
Pluging cadastre-fr v2.0 started...
current cache directory: /home/gast/.josm-latest/plugins/cadastrewms/
Replace source year AAAA by current year 2012
org.openstreetmap.josm.plugins.PluginException: Ein Fehler ist in dem Plugin cadastre-fr aufgetreten.
	at org.openstreetmap.josm.plugins.PluginInformation.load(PluginInformation.java:281)
	at org.openstreetmap.josm.plugins.PluginHandler.loadPlugin(PluginHandler.java:477)
	at org.openstreetmap.josm.plugins.PluginHandler.loadPlugins(PluginHandler.java:535)
	at org.openstreetmap.josm.plugins.PluginHandler.loadLatePlugins(PluginHandler.java:574)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:256)
Caused by: java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)
	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
	at java.lang.reflect.Constructor.newInstance(Constructor.java:532)
	at org.openstreetmap.josm.plugins.PluginInformation.load(PluginInformation.java:272)
	... 4 more
Caused by: java.lang.NoSuchMethodError: org.openstreetmap.josm.tools.I18n.tr(Ljava/lang/String;)Ljava/lang/String;
	at cadastre_fr.CadastrePlugin.refreshConfiguration(CadastrePlugin.java:250)
	at cadastre_fr.CadastrePlugin.<init>(CadastrePlugin.java:166)
	... 9 more

With the plugin package from debian testing josm starts without exception, but still does not use the latest plugin but the one installed under /usr/share.

Attachments (0)

Change History (13)

comment:1 Changed 6 years ago by skyper

Description: modified (diff)

comment:2 Changed 6 years ago by dpaleino

Resolution: invalid
Status: newclosed

Why are you reporting it here?

Please report it in the Debian BTS by using "reportbug josm" from the command line.

Thanks,

David

comment:3 in reply to:  2 Changed 6 years ago by skyper

Resolution: invalid
Status: closedreopened

Replying to dpaleino:

Why are you reporting it here?

Please report it in the Debian BTS by using "reportbug josm" from the command line.

Thanks,

David

Think you got me wrong !

I have the debian packages installed and also a start script for latest ! The problem is with latest from this page. It does not use the downloaded plugins but uses the plugins under /usr/share/josm/plugins.

This setup used to work without problem.

comment:4 Changed 6 years ago by skyper

I cannot try it with older versions as I can not download any plugins due to change of path.

Last edited 6 years ago by skyper (previous) (diff)

comment:5 Changed 6 years ago by skyper

Priority: criticalmajor
Summary: Problem with updating plugins (cadastre does not start) on debianProblem with updating plugins with existing /usr/share/josm/plugins

OK, I summarize, we have two problems here:

  1. josm (from r5036 on) does download plugins to ~/.josm/plugins but only uses plugins from /usr/share/josm/plugins if the plugin exists in this directory.
  2. plugin system for versions pre5036 seems to be totally broken because of path changes.
Last edited 5 years ago by skyper (previous) (diff)

comment:6 Changed 5 years ago by skyper

Still a problem.

r5267

comment:7 Changed 3 years ago by Don-vip

Keywords: linux debian ubuntu added

comment:8 Changed 7 months ago by Don-vip

Cc: sebastic added

Looking at Debian josm-plugins package:

This package contains the following plugins:
 * colorscheme        - Allows creating different color schemes.
 * measurement        - Adds a dialog and a layer to measure length and angle of segments and create measurement paths.
 * openvisible        - Allows opening gpx and osm files that intersect the currently visible screen area.
 * cadastre-fr        - A special handler for the French land registry WMS server.
 * DirectUpload       - Directly uploads GPS Traces from current active layer in JOSM to openstreetmap.org.
 * editgpx            - Anonymizes timestamps and deletes parts of huge GPX tracks very fast.
 * lakewalker         - Helps vectorizing WMS images.
 * routing            - Provides routing capabilities.

So it contains only 8 plugins out the 137 out there (5%). One is non functioning for several years (lakewalker), one is only for French users, one will probably be integrated in core (measurement).

So I propose to simply drop the package. It is not really useful in its current state and only causes problems. Then we can close this ticket.

comment:9 Changed 7 months ago by sebastic

The goal of the josm-plugins package was probably (I wasn't around when it was created) to have plugins compatible with the JOSM version in Debian stable releases, since newer plugin versions tend to require newer JOSM versions. And to not require network connectivity for their installation.

Some of the most useful plugins (e.g. reverter, todo, utilsplugin2) are not yet included, because I haven't found the motivation to do license & copyright review for them. Since this is unlikely to change, I agree that it's probably better to drop the josm-plugins package.

Since Debian is currently in frozen preparation of the stretch release, I'll request removal of the josm-plugins package after the release. I've removed josm-plugins from the josm Recommends to not have it installed by default any more.

comment:10 in reply to:  8 Changed 6 months ago by skyper

Replying to Don-vip:

Looking at Debian josm-plugins package:

The package only uses a valid path like /usr/[local/]share/josm/plugins which should be allowed but on lower priority to the users home directory. This is useful for multiuser systems.

Last edited 6 months ago by skyper (previous) (diff)

comment:11 Changed 6 months ago by Don-vip

Ticket #14702 has been marked as a duplicate of this ticket.

comment:12 Changed 4 months ago by sebastic

Now that stretch has been releases, the removal of the josm-plugins package from unstable & experimental has been requested.

See:

comment:13 Changed 3 months ago by Don-vip

Resolution: fixed
Status: reopenedclosed

Package has been removed: https://tracker.debian.org/news/851395

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.