Modify

Opened 6 years ago

Closed 4 years ago

#7116 closed defect (fixed)

API chokes when uploading undeleted ways/nodes with Precondition Failed

Reported by: Polarbear-j Owned by: team
Priority: major Milestone:
Component: Plugin undelete Version: latest
Keywords: undelete precondition failed Cc: dieterdreist, rickmastfan67, ghia

Description

  • load a deleted way via the 'undelete' plugin
  • upload the way
  • depending on the order JOSM chooses for upload, if it tries to upload the way to be visible again before uploading the re-visible nodes, the API chokes with the following message (WWWWWWW and NNNNNN1 being real way/node numbers) :
PUT http://api.openstreetmap.org/api/0.6/way/WWWWWWW... Precondition Failed
Error header: Precondition failed: Way WWWWWWW requires the nodes with id in (NNNNNN1,NNNNNNN2), which either do not exist, or are not visible.

Warning: error header "Precondition failed: Way WWWWWWW requires the nodes with id in (NNNNNN1,NNNNNNN2), which either do not exist, or are not visible." did not match with an expected pattern

It does not matter if I upload in one single request or 'each object individually'.

Attachments (0)

Change History (6)

comment:1 Changed 4 years ago by Don-vip

Ticket #8156 has been marked as a duplicate of this ticket.

comment:2 Changed 4 years ago by Don-vip

Ticket #8637 has been marked as a duplicate of this ticket.

comment:3 Changed 4 years ago by Don-vip

Cc: dieterdreist rickmastfan67 added
Priority: normalmajor

comment:4 Changed 4 years ago by Don-vip

Ticket #6568 has been marked as a duplicate of this ticket.

comment:5 Changed 4 years ago by Don-vip

Cc: ghia added

comment:6 Changed 4 years ago by Don-vip

Resolution: fixed
Status: newclosed

Should be fixed in [o29555].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.