Modify

Opened 7 years ago

Closed 3 years ago

#6268 closed enhancement (fixed)

[Draft patch] Payment keys are outdated

Reported by: flaimo Owned by: team
Priority: normal Milestone: 15.02
Component: Internal preset Version: tested
Keywords: Cc: Stemby

Description (last modified by skyper)

payment keys have been changed to a strict yes/no/interval list. josm should be updated to reflect those changes in the autocomplete list of keys as well as affected presets (fuel for example).

see http://wiki.openstreetmap.org/wiki/Key:payment

Attachments (2)

ticket_machine_payment.png (46.1 KB) - added by skyper 4 years ago.
screenshot
ticket_machine_payment.diff (6.0 KB) - added by skyper 4 years ago.
patch

Download all attachments as: .zip

Change History (28)

comment:1 Changed 7 years ago by stoecker

Owner: changed from team to flaimo
Status: newneedinfo

JOSM only uses checkboxes for payments (and thus yes/no only), so what do you request?

comment:2 Changed 7 years ago by flaimo

  1. it isn't used on the dialog for fuel stations, that was my mistake; i thought i saw it there. i checked again and it is used on the preset dialog for public transport vending machines for example. besides the fact that the current dialog produces tags that were also wrong after the old notation (payment:credit_cards=yes was never correct, since it expected a list of credit cards instead of "yes"), the checkboxes there should be changed to payment:visa, payment:mastercard, and so on… . see the wiki page for the current list of keys.
  2. same thing for the keys in the autocomplete list when adding a new key/value entry. all keys that used to expect a list of entries as a value (payment:credit_cards, payment:debit_cards, …) now have been split up into yes/no keys (payment:visa, payment:maestro,…)

comment:3 Changed 7 years ago by anonymous

See also #5900.

comment:4 Changed 7 years ago by flaimo

Component: CoreInternal preset
Version: tested

comment:5 Changed 7 years ago by flaimo

Owner: changed from flaimo to team
Status: needinfonew

comment:6 Changed 7 years ago by flaimo

ok, i went through the preset xml. i think the following payment lines should replace the old ones:

item name="Fuel"

      <space />
      <label text="Payment methods: Cash" />
      <check key="payment:coins" text="Coins" default="off" />
      <check key="payment:notes" text="Notes" default="off" />
      <check key="payment:cash" text="Cash (Shortcut for Coins and Notes)" default="on" />
      <space />
      <label text="Payment methods: Debit cards" />
      <check key="payment:maestro" text="Maestro" default="off" />
      <check key="payment:laser" text="Laser" default="off" />
      <space />
      <label text="Payment methods: Credit cards" />
      <check key="payment:mastercard" text="Mastercard" default="off" />
      <check key="payment:visa" text="Visa" default="off" />
      <check key="payment:american_express" text="American Express" default="off" />
      <check key="payment:discover_card" text="Discover Card" default="off" />
      <space />
     <label text="Payment methods: Fuel cards" />
      <check key="payment:dkv" text="DKV" default="off" />
      <check key="payment:uta" text="UTA" default="off" />
      <check key="payment:routex" text="Routex" default="off" />
      <check key="payment:roadrunner" text="Roadrunner" default="off" />
      <check key="payment:svg" text="SVG" default="off" />

item name="Ticket Machine"

      <label text="Payment methods: Cash" />
      <check key="payment:coins" text="Coins" default="off" />
      <check key="payment:notes" text="Notes" default="off" />
      <space />
      <label text="Payment methods: Debit cards" />
      <check key="payment:maestro" text="Maestro" default="off" />
      <check key="payment:laser" text="Laser" default="off" />
      <space />
      <label text="Payment methods: Credit cards" />
      <check key="payment:mastercard" text="Mastercard" default="off" />
      <check key="payment:visa" text="Visa" default="off" />
      <check key="payment:american_express" text="American Express" default="off" />
      <check key="payment:discover_card" text="Discover Card" default="off" />
      <space />
      <label text="Payment methods: Public transport" />
      <check key="payment:oyster" text="Oyster" default="off" />
      <check key="payment:bob" text="Bob" default="off" />

item name="Telephone"

      <label text="Payment methods: Cash" />
      <check key="payment:coins" text="Coins" default="off" />
      <check key="payment:notes" text="Notes" default="off" />
      <space />
      <label text="Payment methods: Debit cards" />
      <check key="payment:maestro" text="Maestro" default="off" />
      <check key="payment:laser" text="Laser" default="off" />
      <space />
      <label text="Payment methods: Credit cards" />
      <check key="payment:mastercard" text="Mastercard" default="off" />
      <check key="payment:visa" text="Visa" default="off" />
      <check key="payment:american_express" text="American Express" default="off" />
      <check key="payment:discover_card" text="Discover Card" default="off" />
      <space />
      <label text="Payment methods: Other" />
      <check key="payment:telephone_card" text="Telephone card" default="off" />

item name="Vending machine"

      <label text="Payment methods: Cash" />
      <check key="payment:coins" text="Coins" default="off" />
      <check key="payment:notes" text="Notes" default="off" />
      <space />
      <label text="Payment methods: Debit cards" />
      <check key="payment:maestro" text="Maestro" default="off" />
      <check key="payment:laser" text="Laser" default="off" />
      <space />
      <label text="Payment methods: Credit cards" />
      <check key="payment:mastercard" text="Mastercard" default="off" />
      <check key="payment:visa" text="Visa" default="off" />
      <check key="payment:american_express" text="American Express" default="off" />
      <check key="payment:discover_card" text="Discover Card" default="off" />

comment:7 Changed 7 years ago by stoecker

Ticket #6272 has been marked as a duplicate of this ticket.

comment:8 Changed 5 years ago by skyper

Description: modified (diff)

The list of different payment keys did grow.

  • Do we need an own preset entry ?
    • How to handle country specific keys ?
  • The preset for amenity=fuel will not fit on many screens if I would add payment keys. Is there a possibility to get two checkboxes in a column (#8735) ?
Last edited 4 years ago by skyper (previous) (diff)

comment:9 Changed 4 years ago by Stemby

Cc: Stemby added

Changed 4 years ago by skyper

Attachment: ticket_machine_payment.png added

screenshot

Changed 4 years ago by skyper

Attachment: ticket_machine_payment.diff added

patch

comment:10 Changed 4 years ago by skyper

I did play with ticket_machine:

  • I am not sure how to handle the old keys which are still valid with no as value to indicate that this payment type is not accepted.
  • The "Electronic Purses and Charge cards" part is nasty, too, as we probably need only one entry per country, but I do not know how we could get it working this way.

Find attached first patch and have a look at the screenshot:

screenshot

Last edited 4 years ago by skyper (previous) (diff)

comment:11 Changed 4 years ago by skyper

Any comments ?

comment:12 Changed 4 years ago by Don-vip

This is really nice, but huge.
I wonder if we should not first made some other improvements to presets mechanism, such as #8958, and maybe collapsable sections that user could show/hide dynamically inside presets window (example for payment methods)

comment:13 in reply to:  12 Changed 4 years ago by bastiK

Replying to Don-vip:

This is really nice, but huge.
I wonder if we should not first made some other improvements to presets mechanism, such as #8958, and maybe collapsable sections that user could show/hide dynamically inside presets window (example for payment methods)

+1

comment:14 in reply to:  12 Changed 4 years ago by skyper

Replying to Don-vip:

This is really nice, but huge.

+1,
I would for sure use the new separator for the payment section but that would even introduce one or two more line though dropping the repeated text.
Ok, I will try to work on some other tickets and to understand validator.

I wonder if we should not first made some other improvements to presets mechanism, such as #8958, and maybe collapsable sections that user could show/hide dynamically inside presets window (example for payment methods)

+1, for collapsable.

#8958 is not that important as I would prefer #8959 (#7797) width option to parse collaps status of sections.
#6990 should also have a higher priority to get multivalues better promoted and for sure my baby would be #8891.

comment:15 Changed 4 years ago by skyper

Summary: Payment keys are outdated[Draft patch] Payment keys are outdated

comment:16 Changed 4 years ago by Don-vip

In 6697/josm:

fix #8359, see #6268 - minor update of amenity=charging_station + initialization of payment chunks

comment:17 Changed 4 years ago by Don-vip

Type: defectenhancement

comment:18 Changed 3 years ago by skyper

As collapsable sections are not available, yet, we could have an own preset for each payment method and use inter-preset links.

comment:19 Changed 3 years ago by Klumbumbus

Milestone: 15.02

comment:20 Changed 3 years ago by Klumbumbus

In 8059/josm:

see #6268 - update payment methods (modified patch by skyper)

comment:21 Changed 3 years ago by Klumbumbus

Resolution: fixed
Status: newclosed

In 8060/josm:

fix #6268 - add a preset_link to the payment method preset to all items with a contact and address preset link (except terminal, churches, some public buildings, schools, nursing home, retirement home, baby hatch, bank)

comment:22 in reply to:  20 ; Changed 3 years ago by skyper

Replying to Klumbumbus:

In 8059/josm:

see #6268 - update payment methods (modified patch by skyper)

Thanks, though I think the public_transport stuff should have an own preset like the telephone cards.

comment:23 in reply to:  22 ; Changed 3 years ago by Klumbumbus

Replying to skyper:

Thanks, though I think the public_transport stuff should have an own preset like the telephone cards.

I don't really understand, can you explain a bit more please?

Actually I will remove some of the public_transport payment methods again since they are not really used.

  • payment:oyster used 0x
  • payment:bob used 1x
  • payment:sube used 0x
  • payment:icsf used 54x (last edited by 5 different users)

comment:24 Changed 3 years ago by Klumbumbus

Resolution: fixed
Status: closedreopened

comment:25 in reply to:  23 Changed 3 years ago by skyper

Replying to Klumbumbus:

Replying to skyper:

Thanks, though I think the public_transport stuff should have an own preset like the telephone cards.

I don't really understand, can you explain a bit more please?

I meant, that public_transport payment methods are only useful for certain items and should not be included in the general payment preset chunk but only in a chunk for public_transport related stuff. Same is true for fuel_cards or telephone_cards which are only useful on gas stations respectively phones.

comment:26 Changed 3 years ago by Klumbumbus

Resolution: fixed
Status: reopenedclosed

In 8076/josm:

fix #6268 - clean up payment methods, remove barely used methods, add fuel cards to fuel preset

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.