Modify

Opened 7 years ago

Closed 7 years ago

#5901 closed defect (fixed)

junctionchecking plugin now broken as of v75

Reported by: rickmastfan67 Owned by: joerg
Priority: blocker Milestone:
Component: Plugin junctionchecking Version: latest
Keywords: Cc:

Description (last modified by rickmastfan67)

Just recently, an updated version of this plugin (v75) was released (this was after r3835, so Ticket #5888 doesn't apply here). After that update was released, it will now no longer load in JOSM. I've tried versions r3831, r3835, r3838, & r3843 and none of them will work with v75 of junctionchecking. Every time I try to load JOSM, it asks me to disable the plugin.

Just thought I would give you guys the heads up about this blocking problem for this plugin.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2011-02-02 02:31:15
Last Changed Author: bastiK
Revision: 3843
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2011-02-01 22:15:06 +0100 (Tue, 01 Feb 2011)
Last Changed Rev: 3843

Identification: JOSM/1.5 (3843 en)
Memory Usage: 88 MB / 455 MB (34 MB allocated, but free)
Java version: 1.6.0_23, Sun Microsystems Inc., Java HotSpot(TM) 64-Bit Server VM
Operating system: Windows 7

Attachments (0)

Change History (6)

comment:1 Changed 7 years ago by rickmastfan67

Description: modified (diff)

comment:2 Changed 7 years ago by stoecker

Can't reproduce crash with current JOSM, but I can understand its reason from Manifest data:

Manifest-Version: 1.0
Ant-Version: Apache Ant 1.7.1
Created-By: 17.1-b03 (Sun Microsystems Inc.)
Author: Jörg Possin
Plugin-Class: org.openstreetmap.josm.plugins.JunctionChecker.JunctionCheckerPlugin
Plugin-Date: ${version.entry.commit.date}
Plugin-Description: Überprüft eine Teilmenge eines aus OSM-Daten erzeugten Digraphen ob eine Kreuzung vorliegt
Plugin-Link: http://wiki.openstreetmap.org/index.php/JOSM/Plugins/JunctionChecking
Plugin-Mainversion: 0.3
Plugin-Version: 75
Main-Class: org.openstreetmap.josm.plugins.JunctionChecker.commandlineinterface.CLI

Plugin-Mainversion must be "3835" or better for a recently built version (0.3 is wrong in any case) or the version checking of JOSM will not work.

I recommend to try to integrate this plugin into OSM-SVN as well. Then:

  • such necessary updates can be done by JOSM developers,
  • plugin is included in translation chain,
  • old version managment is done by JOSM server.

comment:3 Changed 7 years ago by rickmastfan67

Well, it's still not working on r3851 here and refuses to load. Hopefully Jörg can get this fixed and integrated into the OSM-SVN.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2011-02-04 02:31:21
Last Changed Author: bastiK
Revision: 3851
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2011-02-03 22:19:11 +0100 (Thu, 03 Feb 2011)
Last Changed Rev: 3851

Identification: JOSM/1.5 (3851 en)
Memory Usage: 76 MB / 455 MB (33 MB allocated, but free)
Java version: 1.6.0_23, Sun Microsystems Inc., Java HotSpot(TM) 64-Bit Server VM
Operating system: Windows 7
Last edited 7 years ago by rickmastfan67 (previous) (diff)

comment:4 Changed 7 years ago by joerg

Sorry for this late answer, I was on holiday :)

I fixed the bug, it should now run with the newest josm-latest und tested.

I think it is a good idea to integrate the plugin in the official svn-code but I should clean up the code before ;)

comment:5 Changed 7 years ago by stoecker

The other plugins aren't clean as well, so no need to do so before checkin into SVN.

comment:6 Changed 7 years ago by rickmastfan67

Resolution: fixed
Status: newclosed

It's now been updated to v82 and it's working again. I'll close this ticket. ;)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain joerg.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.