Modify

Opened 7 years ago

Closed 3 weeks ago

#5823 closed defect (fixed)

Object count is calculated wrong for decide show confirmation question after move or not

Reported by: KalleLampila Owned by: team
Priority: minor Milestone: 17.11
Component: Core Version: latest
Keywords: move Cc:

Description (last modified by mdk)

When object count is calculated for decide show confirmation question after move or not, nodes are count many times, if they are select direct and via ways or via many ways.

To reproduce:

make way with 10 nodes. Select all nodes and way and move them. Confirmation question is incorrectly showed after move.

OR:

Make two ways. that use same 10 nodes. Select both ways and move. Confirmation question is incorrectly showed after move.

Attachments (0)

Change History (3)

comment:1 Changed 15 months ago by mdk

Description: modified (diff)

The problem is still open, except that the limit is now at 20 objects.

Do the following:

  • draw a closed way of 19 nodes.
  • select only the way and move it.

-> Warning dialogue with "You moved more than 20 elements. ..."

More than 20 means at least 21. How could this happens if I only select the way? Even if I add the selected nodes to the way, I get only 20. But a closed way contains the first node as the last node twice. So we reach 21.

Delete one of the nodes, so we got a closed way of 18 nodes.
Moving the way cause no warning, but if you select at least one node of the closed way together with the way, you get the warning again while moving the way.

A simple solution would be to count only the nodes affected (so ignoring ways and relations). Just go threw the selected tree and collect all nodes in a HashSet.
We could not really move a way or a relation in JOSM. We could only move nodes. If we move nodes which are part of a way, we don't really move the way as long as we luckily selected all nodes of the way. For me it would be more clear to talk and warn about moved nodes instead of moved objects.

comment:2 Changed 3 weeks ago by Don-vip

Milestone: 17.11

comment:3 Changed 3 weeks ago by Don-vip

Resolution: fixed
Status: newclosed

In 13062/josm:

fix #5823 - fix calculation of "moved many elements" warning

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.