Modify

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#5814 closed defect (fixed)

middleclick on way getting drawn locks josm completely

Reported by: malenki Owned by: team
Priority: blocker Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

How to reproduce
Draw a way with at least two nodes (yes :))
While remaining in Drawing mode, do middleclick on the way being drawn and hold for about a second
JOSM locks up completely and needs to get killed. No debug output on console.

Attachments (0)

Change History (13)

comment:1 Changed 7 years ago by Cobra

I can confirm this. Other modes, like select or extrude, are working fine.

r3721 (the oldest one I have) is crashing the same way so this doesn't seem to be caused by recent changes.

some additional information:

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2011-01-04 02:31:13
Last Changed Author: stoecker
Revision: 3772
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2011-01-03 14:04:19 +0100 (Mon, 03 Jan 2011)
Last Changed Rev: 3772

Identification: JOSM/1.5 (3772 en)
Memory Usage: 253 MB / 888 MB (215 MB allocated, but free)
Java version: 1.6.0_22, Sun Microsystems Inc., Java HotSpot(TM) 64-Bit Server VM
Operating system: Linux

comment:2 Changed 7 years ago by rickmastfan67

I can also confirm this on Windows 7 x64 on both 3771 & 3773.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2011-01-05 02:31:07
Last Changed Author: Upliner
Revision: 3773
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2011-01-04 16:10:43 +0100 (Tue, 04 Jan 2011)
Last Changed Rev: 3773

Identification: JOSM/1.5 (3773 en)
Memory Usage: 56 MB / 455 MB (8 MB allocated, but free)
Java version: 1.6.0_23, Sun Microsystems Inc., Java HotSpot(TM) 64-Bit Server VM
Operating system: Windows 7

comment:3 Changed 7 years ago by jttt

Resolution: fixed
Status: newclosed

In [3782/josm]:

Fix #5814 middleclick on way getting drawn locks josm completely

comment:4 Changed 7 years ago by dieterdreist

Ticket #5832 has been marked as a duplicate of this ticket.

comment:5 Changed 7 years ago by Cobra

Resolution: fixed
Status: closedreopened

Still exists for me in r3782.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2011-01-10 02:31:22
Last Changed Author: jttt
Revision: 3782
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2011-01-09 18:19:37 +0100 (Sun, 09 Jan 2011)
Last Changed Rev: 3782

comment:6 Changed 7 years ago by stoecker

Ticket #5832 has been marked as a duplicate of this ticket.

comment:7 Changed 7 years ago by Cobra

r3782 is even a regression. Now other modes, which are working fine in r3780, fail as well.

I tested draw, which fails in 3780 and 3782, select and extrude fail in 3782 only but are working in 3780.

comment:8 in reply to:  7 Changed 7 years ago by anonymous

Replying to Cobra:

r3782 is even a regression. Now other modes, which are working fine in r3780, fail as well.

confirm

comment:8 in reply to:  7 Changed 7 years ago by anonymous

Replying to Cobra:

r3782 is even a regression. Now other modes, which are working fine in r3780, fail as well.

confirm

comment:9 Changed 7 years ago by malenki

The last anonymous was me.

comment:10 Changed 7 years ago by jttt

Resolution: fixed
Status: reopenedclosed

In [3783/josm]:

Fix #5814 middleclick on way getting drawn locks josm completely

comment:11 Changed 7 years ago by Cobra

this one is working. Thanks for fixing.

comment:12 Changed 7 years ago by malenki

/me seconds Cobra again :)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.