Modify

Opened 7 years ago

Closed 6 years ago

#5713 closed defect (fixed)

JOSM doesn't upload changesets sometimes …

Reported by: andre-r@… Owned by: team
Priority: blocker Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

… but tells me, that it's still uploading some things. It stays in that state until I cancel the upload process, but if I restart the upload, I have the same issue again. Even if I restart the whole software and load the changes from a loccal *.osm copy, it doesn't work every now and then.

I tried it in different versions during the last couple of days but I get the same issue over and over again.

I use Win7 64 bits and I start the Java interpreter with 1024 MB RAM. I use the most recent version of Java.

Attachments (0)

Change History (10)

comment:1 Changed 7 years ago by bastiK

Can you give a bit of a history: Was there a time when you did not have this problem? Next time you could verify that the problem is related to josm at all: Try an oder version that you know is ok. If it doesn't upload either, it's probably a server issue.

comment:2 Changed 7 years ago by anonymous

I watched the same behavior at Version 3695, Suse Linux 11.2. Yesterday I installed 3701 and since then this did not happen again.

Wolfgang H

comment:3 Changed 7 years ago by bastiK

There is no big difference between 3695 and 3701

If the problem continues and it's really a problem with josm (and not a server issue) we are very much interested in it. One important point to clarify: Are there old versions that work in such a situation and newer versions that are clearly broken or does it fail / succeed no matter what version you use? Old versions can be downloaded here: http://josm.openstreetmap.de/download/ I recommend the previous tested versions 3592, 3376, 3208.

comment:4 Changed 7 years ago by zut

Same Problem with 3701 here, not shure if it is josm or the server. josm tells me "changeset 6589717 successfully opened" and stays this way until i cancel. Here the output from command line:

GET http://www.openstreetmap.org/api/0.6/map?bbox=10.326844399999999,52.5404711,10.3512481,52.5548806
GET http://www.openstreetmap.org/api/0.6/trackpoints?bbox=10.326844399999999,52.5404711,10.3512481,52.5548806&page=0
GET http://www.openstreetmap.org/api/0.6/trackpoints?bbox=10.326844399999999,52.5404711,10.3512481,52.5548806&page=1
PUT http://www.openstreetmap.org/api/0.6/changeset/create... OK
POST http://www.openstreetmap.org/api/0.6/changeset/6589596/upload... Der Fehler wird ignoriert, da das Herunterladen abgebrochen wurde. Die Fehlermeldung war: org.openstreetmap.josm.io.OsmTransferException: java.net.SocketException: Socket closed
PUT http://www.openstreetmap.org/api/0.6/changeset/create... OK
POST http://www.openstreetmap.org/api/0.6/changeset/6589648/upload... Der Fehler wird ignoriert, da das Herunterladen abgebrochen wurde. Die Fehlermeldung war: org.openstreetmap.josm.io.OsmTransferException: java.net.SocketException: Socket closed
PUT http://www.openstreetmap.org/api/0.6/changeset/create... OK
POST http://www.openstreetmap.org/api/0.6/changeset/6589669/upload... Der Fehler wird ignoriert, da das Herunterladen abgebrochen wurde. Die Fehlermeldung war: org.openstreetmap.josm.io.OsmTransferException: java.net.SocketException: Socket closed
PUT http://www.openstreetmap.org/api/0.6/changeset/create... OK
POST http://www.openstreetmap.org/api/0.6/changeset/6589699/upload... Der Fehler wird ignoriert, da das Herunterladen abgebrochen wurde. Die Fehlermeldung war: org.openstreetmap.josm.io.OsmTransferException: java.net.SocketException: Socket closed
PUT http://www.openstreetmap.org/api/0.6/changeset/create... OK
POST http://www.openstreetmap.org/api/0.6/changeset/6589717/upload...

right now, version 3592 seems to have the same problem. Seems like a server side problem to me.

comment:5 Changed 7 years ago by Larry0ua

Hi All

I have the same problem with my Win7x86, java 1.6.0_22. Online-editors work with saving faster a lot

Regards

comment:6 Changed 7 years ago by anonymous

You should probably add some "timeout" error message if the connection is failing.

comment:7 Changed 7 years ago by wolfgang@…

Now I have the same problem on openSUSE 11.2 (x86_64) kernel 2.6.31.14-0.4-desktop #1 SMP PREEMPT 2010-10-25 08:45:30 +0200 x86_64 with java-1_6_0-sun-1.6.0.u22-1.2.1.x86_64 and josm 3701; today at ca 0:15 german time (MEZ), about 900 Objects.

As a workaround I tried the upload-option 2 ("Objekte in mehreren Paketen hochladen. Paketgröße:")

The field packetsize is not visible, so I let it at the default value of 1. It took some time, and from time to time an object hung, but all of data was uploaded to the server.

Hth, Wolfgang

comment:8 Changed 7 years ago by Fabi2

Looks like a server side connection close. This probably is a high server load issue due to the bing imagery.

comment:9 Changed 7 years ago by wolfgang@…

Yes, I think so too. I succeeded to put a 10 into the invisible field "packet size" and will use josm this way for the next time.

I will make a test with mercaartor as soon as it is possible to view bing images in that editor. The error should be the same.

Regards, Wolfgang

comment:10 Changed 6 years ago by stoecker

Resolution: fixed
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.