Modify

Opened 7 years ago

Closed 19 months ago

#5509 closed enhancement (fixed)

Sorting property lists

Reported by: anonymous Owned by: ce
Priority: normal Milestone: 15.08
Component: Internal preset Version:
Keywords: sorting Cc: Klumbumbus

Description (last modified by stoecker)

Hi, wouldn't it be easy to sort the lists showing up the properties in the single presets?

For instance the vending machine preset drop down box for the machines products would be easier to understand if it is sorted alphabeticaly, cause you know what you are looking for at this moment.

Attachments (1)

5509.patch (1.3 KB) - added by simon04 6 years ago.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 7 years ago by stoecker

Not generally. The order is defined by the preset code itself. Maybe we can add a sort keyword, so the list can get sorted when preset author wants it.

comment:2 Changed 6 years ago by simon04

Component: CoreInternal preset
Owner: changed from team to ce
Summary: Sorting property lists[Patch] Sorting property lists

Sorting is easier done within the preset. But how about I18n?

Changed 6 years ago by simon04

Attachment: 5509.patch added

comment:3 Changed 5 years ago by stoecker

In [4559/josm]:

sort some presets - see #5509 - patch by simon04

comment:4 Changed 5 years ago by stoecker

Description: modified (diff)
Summary: [Patch] Sorting property listsSorting property lists

We could add a sort property, probably set to "true" as default.

comment:5 in reply to:  4 Changed 3 years ago by skyper

Replying to stoecker:

We could add a sort property, probably set to "true" as default.

Think it is not default atm but there is an option to sort now.

comment:6 Changed 2 years ago by skyper

taggingpreset.sortmenu=true only works for the menu but not for values of combo_box for example.

comment:7 Changed 23 months ago by simon04

Ticket #11547 has been marked as a duplicate of this ticket.

comment:8 Changed 23 months ago by Klumbumbus

Cc: Klumbumbus added

comment:9 Changed 23 months ago by simon04

Resolution: fixed
Status: newclosed

In 8493/josm:

fix #5509 - Presets: sort property lists by display name

Sorting is on by default and can be controlled with preference key
taggingpreset.sortvalues.

comment:10 Changed 23 months ago by simon04

Milestone: 15.07

comment:11 Changed 21 months ago by Don-vip

Milestone: 15.0715.08

Milestone renamed

comment:12 Changed 19 months ago by osm.mapper999@…

Resolution: fixed
Status: closedreopened

I think it would still be nice to have a possibility to have a non-alphabetical sorting. For example when tagging railway signal states the reasonable order for a German Vr signal would be railway:signal:states=vr0;vr1;vr2;off;?. Now you have to come up with some creative names for the label, so that they are shown and applied in the correct order.
(see also https://github.com/rurseekatze/OpenRailwayMap/pull/357)

comment:13 Changed 19 months ago by simon04

Resolution: fixed
Status: reopenedclosed

Please do not re-open closed tickets from earlier milestones! Instead, create an new one: #11926

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain ce.
as The resolution will be set. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.