Modify

Opened 7 years ago

Closed 7 years ago

#5358 closed defect (fixed)

after auto update roadsign

Reported by: Luebeck Owned by: stoecker
Priority: blocker Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2010-05-27 01:31:44
Last Changed Author: framm
Revision: 3280
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2010-05-26 17:16:28 +0200 (Wed, 26 May 2010)
Last Changed Rev: 3280

Memory Usage: 52 MB / 989 MB (19 MB allocated, but free)
Java version: 1.6.0_21, Sun Microsystems Inc., Java HotSpot(TM) Client VM
Operating system: Windows 7

Plugins: undelete,openstreetbugs,PicLayer,touchscreenhelper,livegps,AddrInterpolation,turnrestrictions,walkingpapers,wmsplugin,wayselector,public_transport,RoadSigns,remotecontrol,surveyor,OpeningHoursEditor
Plugin remotecontrol (Version: 22702)
Plugin undelete (Version: 22365)
Plugin openstreetbugs (Version: 22684)
Plugin PicLayer (Version: 22549)
Plugin touchscreenhelper (Version: 21576)
Plugin livegps (Version: 21706)
Plugin AddrInterpolation (Version: 21710)
Plugin turnrestrictions (Version: 22477)
Plugin walkingpapers (Version: 22549)
Plugin wmsplugin (Version: 22686)
Plugin wayselector (Version: 21706)
Plugin public_transport (Version: 22048)
Plugin OpeningHoursEditor
Plugin surveyor (Version: 21706)

java.lang.reflect.InvocationTargetException

at java.awt.EventQueue.invokeAndWait(Unknown Source)
at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:88)
at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:129)
at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
at java.util.concurrent.FutureTask.run(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

Caused by: java.lang.NoSuchMethodError: org.openstreetmap.josm.data.osm.DataSet.addSelectionListener(Lorg/openstreetmap/josm/data/SelectionChangedListener;)V

at org.openstreetmap.josm.plugins.osb.gui.OsbDialog.showNotify(OsbDialog.java:236)
at org.openstreetmap.josm.gui.dialogs.DialogsPanel.add(DialogsPanel.java:84)
at org.openstreetmap.josm.gui.dialogs.DialogsPanel.initialize(DialogsPanel.java:43)
at org.openstreetmap.josm.gui.MapFrame.initializeDialogsPane(MapFrame.java:226)
at org.openstreetmap.josm.Main.addLayer(Main.java:233)
at org.openstreetmap.josm.actions.downloadtasks.DownloadOsmTask$DownloadTask.finish(DownloadOsmTask.java:157)
at org.openstreetmap.josm.gui.PleaseWaitRunnable$1.run(PleaseWaitRunnable.java:90)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.Dialog$1.run(Unknown Source)
at java.awt.Dialog$3.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.awt.Dialog.show(Unknown Source)
at java.awt.Component.show(Unknown Source)
at java.awt.Component.setVisible(Unknown Source)
at java.awt.Window.setVisible(Unknown Source)
at java.awt.Dialog.setVisible(Unknown Source)
at org.openstreetmap.josm.gui.progress.PleaseWaitProgressMonitor$3.run(PleaseWaitProgressMonitor.java:83)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (3)

comment:1 Changed 7 years ago by jttt

Owner: changed from team to stoecker

That is problem in OpenStreetBugs plugin. I have used method from r3416 but I forgot to update plugin.main.version. JOSM update should fix it. It's strange that osb plugin got downloaded, because you're using josm 3280, but main.version was set to 3408 when I've committed the incompatible change.

@Dirk, can you please remove revision 22684 from plugin update site? I've already committed new version with correct plugin.main.version

comment:2 Changed 7 years ago by bastiK

@jttt: There is trick to fix a forgotten update of Mainversion (but it's too late for that now):

  • revert the change and update
  • wait till the server has registered the update
  • recommit the change including new Mainversion

I tried it once, it works. :)

comment:3 Changed 7 years ago by stoecker

Resolution: fixed
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain stoecker.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.