Modify

Opened 8 years ago

Closed 8 years ago

#4795 closed defect (fixed)

josm stalls connecting 2 ways or merging 2 nodes

Reported by: skyper Owned by: team
Priority: blocker Milestone:
Component: Core Version: latest
Keywords: connect stall relation node Cc:

Description

I merged 2 files and started conflict solution. I only solved 4 conflicts so far, and I did 8 changes. (Do not really no which one cause the list is minimized and nothing useful on the console.)
I conflict was the last conflict in the list (way with ref="B3, B31") and the other 3, I think, were nodes.
I did not delete this way and than split it twice. I took the last part (id:0) unglued the first node (city-sign) and moved it.
I unglued the second node of id:48961958 and merged it with the first node of the other way.
Trying to connect the two ways rised the exception.

r3155 and sun

Attachments (4)

bug_4795.tar.bz2 (206.6 KB) - added by skyper 8 years ago.
2 osm, console log
console_4795_2.log (10.6 KB) - added by skyper 8 years ago.
console-log second try
bug_4795_nodes.osm.bz2 (130.5 KB) - added by skyper 8 years ago.
osm
4795_demo.osm (761 bytes) - added by skyper 8 years ago.
demo-osm

Download all attachments as: .zip

Change History (14)

Changed 8 years ago by skyper

Attachment: bug_4795.tar.bz2 added

2 osm, console log

comment:1 Changed 8 years ago by skyper

Priority: criticalblocker

The bug is reproducable.

Just solve the last conflict with way id:52516132 keeping my and then split of the last segment (city_sign).

Changed 8 years ago by skyper

Attachment: console_4795_2.log added

console-log second try

comment:2 Changed 8 years ago by skyper

Keywords: connect stall added

It happened again. I expected a dialog because of differences in relation membership but nothing happend.

r3166, sun

comment:3 in reply to:  1 Changed 8 years ago by anonymous

Replying to skyper:

The bug is reproducable.

Just solve the last conflict with way id:52516132 keeping my and then split of the last segment (city_sign).

For me the last node (end node) is a city_sign. How can I split the way there? I tried to split (P) at the last but one node of that way, but no problem so far.

comment:4 Changed 8 years ago by anonymous

The bug happens when connecting ways with different memberships of relation, instead of offerering a dialog of tag/membership JOSM stalls.

It did happen quite often these days.
I have a look and try to find an example
.

comment:5 Changed 8 years ago by skyper

It also happens merging 2 nodes.

Again there are differences with tags and relation-membership. Use id:655382271 and id:0 a bit more west of it. (both addr:housenumber=54)

Changed 8 years ago by skyper

Attachment: bug_4795_nodes.osm.bz2 added

osm

comment:6 Changed 8 years ago by skyper

Keywords: relation node added
Summary: josm stalls connecting 2 waysjosm stalls connecting 2 ways or merging 2 nodes

comment:7 Changed 8 years ago by skyper

I made a demo for ways:

r3174

Changed 8 years ago by skyper

Attachment: 4795_demo.osm added

demo-osm

comment:8 Changed 8 years ago by skyper

just try to connect the two ways

comment:9 Changed 8 years ago by bastiK

Cannot reproduce for any of these examples. I assume, the last example crashes each time? I just get the normal merge dialog.

comment:10 Changed 8 years ago by anonymous

Resolution: fixed
Status: newclosed

I only can reproduce it with my old preference-file. After moving my preferences out of the way and start with an empty pref-dir everything works fine. Wonder why I have to through away my prefs every 2 weeks.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.