Modify

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#4705 closed defect (fixed)

Exception when drawing a closed way

Reported by: bastiK Owned by: team
Priority: blocker Milestone:
Component: Core Version: latest
Keywords: area, exception, closed way Cc:

Description

What steps will reproduce the problem?

  1. Draw a closed way

This is from [3102].

Build-Date: 2010-03-10 10:02:37
Revision: 3102
Is-Local-Build: true

Memory Usage: 26 MB / 297 MB (4 MB allocated, but free)
Java version: 1.6.0_15, Sun Microsystems Inc., Java HotSpot(TM) Client VM
Operating system: Linux

Dataset consistency test:
No problems found


Plugins: buildings_tools,measurement,multipoly-convert,openvisible,osmarender,photo_geotagging,remotecontrol,tageditor,terracer,validator,wmsplugin
Plugin wmsplugin Version: 19992
Plugin openvisible Version: 20067
Plugin tageditor Version: 20334
Plugin remotecontrol Version: 19946
Plugin buildings_tools Version: 20269
Plugin validator Version: 20366
Plugin multipoly-convert Version: 1.1
Plugin osmarender Version: 19419
Plugin terracer Version: 20084
Plugin photo_geotagging Version: 19873
Plugin measurement Version: 19681

java.lang.UnsupportedOperationException
	at java.util.Collections$UnmodifiableCollection.clear(Collections.java:1037)
	at org.openstreetmap.josm.actions.mapmode.DrawAction.mouseReleased(DrawAction.java:510)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:273)
	at java.awt.Component.processMouseEvent(Component.java:6263)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3267)
	at java.awt.Component.processEvent(Component.java:6028)
	at java.awt.Container.processEvent(Container.java:2041)
	at java.awt.Component.dispatchEventImpl(Component.java:4630)
	at java.awt.Container.dispatchEventImpl(Container.java:2099)
	at java.awt.Component.dispatchEvent(Component.java:4460)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4574)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4238)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4168)
	at java.awt.Container.dispatchEventImpl(Container.java:2085)
	at java.awt.Window.dispatchEventImpl(Window.java:2475)
	at java.awt.Component.dispatchEvent(Component.java:4460)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:599)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

Attachments (1)

josm_error_area_closing.png (170.0 KB) - added by telegnom 8 years ago.

Download all attachments as: .zip

Change History (9)

Changed 8 years ago by telegnom

Attachment: josm_error_area_closing.png added

comment:1 Changed 8 years ago by telegnom

Priority: normalblocker

Bug still there in version 3105.

Build-Date: 2010-03-10 17:26:14
Revision: 3105
Is-Local-Build: true

Memory Usage: 207 MB / 1102 MB (87 MB allocated, but free)
Java version: 1.6.0_15, Sun Microsystems Inc., Java HotSpot(TM) 64-Bit Server VM
Operating system: Linux

Dataset consistency test:
No problems found


Plugins: DirectUpload,buildings_tools,dataimport,editgpx,lakewalker,multipoly,openstreetbugs,photo_geotagging,remotecontrol,terracer,validator,wmsplugin
Plugin openstreetbugs Version: 19463
Plugin wmsplugin Version: 19992
Plugin editgpx Version: 19683
Plugin dataimport Version: 20267
Plugin remotecontrol Version: 19946
Plugin buildings_tools Version: 20269
Plugin DirectUpload Version: 19700
Plugin validator Version: 20366
Plugin lakewalker Version: 19624
Plugin terracer Version: 20084
Plugin photo_geotagging Version: 19873
Plugin multipoly Version: 19456

java.lang.UnsupportedOperationException
	at java.util.Collections$UnmodifiableCollection.clear(Collections.java:1037)
	at org.openstreetmap.josm.actions.mapmode.DrawAction.mouseReleased(DrawAction.java:510)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:273)
	at java.awt.Component.processMouseEvent(Component.java:6263)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3267)
	at java.awt.Component.processEvent(Component.java:6028)
	at java.awt.Container.processEvent(Container.java:2041)
	at java.awt.Component.dispatchEventImpl(Component.java:4630)
	at java.awt.Container.dispatchEventImpl(Container.java:2099)
	at java.awt.Component.dispatchEvent(Component.java:4460)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4574)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4238)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4168)
	at java.awt.Container.dispatchEventImpl(Container.java:2085)
	at java.awt.Window.dispatchEventImpl(Window.java:2475)
	at java.awt.Component.dispatchEvent(Component.java:4460)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:599)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

comment:2 Changed 8 years ago by telegnom

Keywords: area exception closed way added; template_report removed
Version: latest

comment:3 Changed 8 years ago by bastiK

Ticket #4714 has been marked as a duplicate of this ticket.

comment:4 Changed 8 years ago by Gubaer

Resolution: fixed
Status: newclosed

(In [3108]) fixed #4705: Exception when drawing a closed way

comment:5 Changed 8 years ago by mjulius

Ticket #4717 has been marked as a duplicate of this ticket.

comment:6 Changed 8 years ago by anonymous

Ticket #4720 has been marked as a duplicate of this ticket.

comment:7 Changed 8 years ago by anonymous

Ticket #4721 has been marked as a duplicate of this ticket.

comment:8 Changed 8 years ago by anonymous

(I am the person who reported #4721) I confirm that I no longer see this error in r3126 or later.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.