Modify

Opened 8 years ago

Closed 8 years ago

#4557 closed defect (fixed)

NullPointerException on launch

Reported by: anonymous Owned by: team
Priority: blocker Milestone:
Component: Core Version: latest
Keywords: exception blocker Cc: skyper

Description

What steps will reproduce the problem?

  1. Upgrade to 3009
  2. Launch JOSM

What is the expected result?
I obviously expected JOSM to start.

What happens instead?
Still on Loading-Window, it does not handle an exception.

Additionally, have a look at the titlebar on the screenshot and insert an i into a suitable place.

Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2010-02-18 02:31:18
Last Changed Author: bastiK
Revision: 3009
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2010-02-17 23:48:31 +0100 (Wed, 17 Feb 2010)
Last Changed Rev: 3009

Memory Usage: 79 MB / 81 MB (54 MB allocated, but free)
Java version: 1.6.0_17, Apple Inc., Java HotSpot(TM) 64-Bit Server VM
Operating system: Mac OS X


Plugins: DirectUpload,openstreetbugs,validator

java.lang.NullPointerException
	at org.openstreetmap.josm.io.MirroredInputStream.getZipEntry(MirroredInputStream.java:102)
	at org.openstreetmap.josm.gui.tagging.TaggingPreset.readFromPreferences(TaggingPreset.java:648)
	at org.openstreetmap.josm.gui.preferences.TaggingPresetPreference.initialize(TaggingPresetPreference.java:84)
	at org.openstreetmap.josm.Main.<init>(Main.java:214)
	at org.openstreetmap.josm.gui.MainApplication.<init>(MainApplication.java:49)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:193)

Attachments (1)

Bildschirmfoto 2010-02-18 um 08.51.12.png (467.3 KB) - added by anonymous 8 years ago.
Screenshot

Download all attachments as: .zip

Change History (10)

Changed 8 years ago by anonymous

Screenshot

comment:1 Changed 8 years ago by anonymous

Version: latest

comment:2 Changed 8 years ago by jttt

This is duplicate of #4551. I'll keep this ticket open for today so it's visible for everybody and we don't get futher duplicate tickets...

comment:3 Changed 8 years ago by anonymous

Ticket #4558 has been marked as a duplicate of this ticket.

comment:4 Changed 8 years ago by anonymous

Ticket #4559 has been marked as a duplicate of this ticket.

comment:5 Changed 8 years ago by anonymous

Ticket #4560 has been marked as a duplicate of this ticket.

comment:6 Changed 8 years ago by skyper

Cc: skyper added
Keywords: exception blocker added; template_report removed

Same with linux, sun-java 6.

comment:7 Changed 8 years ago by anonymous

Ticket #4563 has been marked as a duplicate of this ticket.

comment:8 in reply to:  2 Changed 8 years ago by mjulius

Replying to jttt:

This is duplicate of #4551. I'll keep this ticket open for today so it's visible for everybody and we don't get futher duplicate tickets...

That didn't do it ... :-(

comment:9 Changed 8 years ago by mjulius

Resolution: fixed
Status: newclosed

Closing this now because we have a new -latest.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.