Modify

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#4551 closed defect (fixed)

r3007 causes an NPE on startup

Reported by: Daeron Owned by: team
Priority: blocker Milestone:
Component: Core Version:
Keywords: Cc: malenki

Description

JOSM is unusable after r3007 as it causes an NPE on startup: (with clean config)

Build-Date: 2010-02-17 23:41:48		
Revision: 3007
Is-Local-Build: true

Memory Usage: 23 MB / 910 MB (7 MB allocated, but free)
Java version: 1.6.0_17, Sun Microsystems Inc., Java HotSpot(TM) 64-Bit Server VM
Operating system: Linux



java.lang.NullPointerException
	at org.openstreetmap.josm.io.MirroredInputStream.getZipEntry(MirroredInputStream.java:102)
	at org.openstreetmap.josm.gui.tagging.TaggingPreset.readFromPreferences(TaggingPreset.java:648)
	at org.openstreetmap.josm.gui.preferences.TaggingPresetPreference.initialize(TaggingPresetPreference.java:84)
	at org.openstreetmap.josm.Main.<init>(Main.java:214)
	at org.openstreetmap.josm.gui.MainApplication.<init>(MainApplication.java:49)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:193)

Attachments (0)

Change History (4)

comment:1 Changed 8 years ago by malenki

r3009 also.
The strange thing is that after clicking away the error message, the window "Main window is being generated" remains. Clicking at it causes it to disappear but Josm still runs.

comment:2 Changed 8 years ago by malenki

Cc: malenki added

comment:3 Changed 8 years ago by jttt

Resolution: fixed
Status: newclosed

(In [3011]) Fix #4551 r3007 causes an NPE on startup

comment:4 Changed 8 years ago by anonymous

Ticket #4555 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.