Modify

Opened 8 years ago

Closed 8 years ago

#4406 closed defect (fixed)

tags disapear: merging node with ID:0 and tag to existing node without tags

Reported by: skyper Owned by: team
Priority: blocker Milestone:
Component: Core Version: latest
Keywords: merge node way r-2010-01-blocker Cc: skyper

Description

I merge two nodes (north to south).
One with ID:0 and tags to one with ID and without tag.
Result is a node without any tags and the old ID.

I lost all the tags of the node !!!

cu skyper

version 2878

Attachments (1)

josm_bug_4406.osm.bz2 (58.1 KB) - added by skyper 8 years ago.
osm

Download all attachments as: .zip

Change History (11)

comment:1 Changed 8 years ago by skyper

Cc: skyper added

comment:2 Changed 8 years ago by t-i

Keywords: way added
Priority: criticalblocker

Same happens here:
existing and new node are merged -> all tags disappear.

Even when combining ways two new ways:

select two new ways and press 'c' -> all tags disappear.

comment:3 Changed 8 years ago by bastiK

Can you reproduce this error? Can you attach a *.osm file where this error occurs?

comment:4 in reply to:  3 Changed 8 years ago by anonymous

Replying to bastiK:

Can you reproduce this error? Can you attach a *.osm file where this error occurs?

Yeah, Here you go. Look for id:25207466.[[BR]]

  1. select node id:0, tag: noexit=yes.
  2. merge this node to id:25207466. -> tag lost

cu skyper

Changed 8 years ago by skyper

Attachment: josm_bug_4406.osm.bz2 added

osm

comment:5 Changed 8 years ago by skyper

forgot: version 2949

comment:6 Changed 8 years ago by bastiK

I still cannot reproduce.

comment:7 in reply to:  6 Changed 8 years ago by skyper

Replying to bastiK:

I still cannot reproduce.

Please try to create your own, new node and try it again. The file was a new osm just downloaded. I try to gather some more information, but so far I know that this bug (nodes) is around quite some time and it does not happen every time.

comment:8 Changed 8 years ago by Gubaer

Keywords: r-2010-01-blocker added

I'll flag it as blocker for the next release.

comment:9 Changed 8 years ago by skyper

This bug only appears with new nodes created on this session. That is why you can not reproduce it with a saved osm. Please just copy a existing node with tags or create a new one and try to merge it.

comment:10 Changed 8 years ago by jttt

Resolution: fixed
Status: newclosed

(In [2996]) Fix #4406 tags disapear: merging node with ID:0 and tag to existing node without tags

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.