Modify

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#4378 closed defect (fixed)

r2862 hangs on startup while processing plugin files

Reported by: anonymous Owned by: team
Priority: blocker Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

Just updated to r2862 and now when I try to start josm, it hangs on the splash screen saying "Processing plugin files...". The terminal says:


Build-Date: 2010-01-15 12:33:41
Revision: 2862
Is-Local-Build: true

Warning: no preference 'proxy.policy' found.
The proxy will not be used.
Defaults for pluginmanager.version differ: false != 0


That last line looks as if it could be relevant?

I have tried deleting the preferences and all of the plugins. With no plugins installed
it will start OK. If I install any plugins, it hangs.

Any thoughts?

Attachments (0)

Change History (13)

comment:1 Changed 8 years ago by glebius

I confirm this problem with r2862.

comment:2 Changed 8 years ago by Gubaer

I can't reproduce here (Windows 7, Java 5). Can you give me any additonal information?

comment:3 in reply to:  2 Changed 8 years ago by anonymous

Replying to Gubaer:

I can't reproduce here (Windows 7, Java 5). Can you give me any additonal information?

Linux (ubuntu Hardy)
java version "1.6.0_17"

Without any plugins installed, it starts up OK. I now install wmsplugin and when I restart
it hangs at the splash (which is now saying "Processing plugin site cache files...". The terminal window says: Defaults for pluginmanager.version differ: false != 0

What else can I tell you?

comment:4 Changed 8 years ago by Gubaer

Operating System? It isn't a windows flavour, is it?

Java VM?

comment:5 in reply to:  4 Changed 8 years ago by Gubaer

Replying to Gubaer:

Operating System? It isn't a windows flavour, is it?

Java VM?

Hmm, sorry, overread that you already wrote "Linux (ubuntu Hardy) java version "1.6.0_17" "

comment:6 Changed 8 years ago by bastiK

The update dialog is hidden behind the splash screen and so it blocks. (r2863, Ubuntu Karmic)

comment:7 in reply to:  6 Changed 8 years ago by anonymous

Replying to bastiK:

The update dialog is hidden behind the splash screen and so it blocks. (r2863, Ubuntu Karmic)

Well spotted!

By tabbing through the windows, I can see the outline of some hidden dialog but can't raise it above the splash.

comment:8 Changed 8 years ago by glebius

I'm running FreeBSD and Java 1.6.0_03-p4. r2864 hangs same way.

Yes, I see "Update plugins" dialog outline in windows list, but there is no such window in window manager.

comment:9 Changed 8 years ago by stoecker

Resolution: duplicate
Status: newclosed

comment:10 Changed 8 years ago by stoecker

Closed as duplicate of #4365.

comment:11 Changed 8 years ago by Gubaer

Resolution: duplicatefixed

(In [2865]) fixed #4378: r2862 hangs on startup while processing plugin files
fixed #4365: "Do you want to update plugins" request shown behind Splashscreen
Turned splash screen into an undecorated JFrame. Works on Windows 7 and Ubuntu. Please check again.

comment:12 in reply to:  11 Changed 8 years ago by anonymous

fixed for me on Linux (ubuntu Hardy) java version "1.6.0_17"

Thanks.

comment:13 Changed 8 years ago by bastiK

Ticket #4383 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.