Modify

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#4333 closed defect (fixed)

NullPointerException occurs when downloading map data from OSM server

Reported by: cam_daw@… Owned by: team
Priority: blocker Milestone:
Component: Core Version: latest
Keywords: NullPointerException, crash, download Cc:

Description

After clicking on the "Download map data from OSM server" button in JOSM, selecting any small area to download, and pressing the "Download" button. JOSM crashes with an Unexpected exception.
When looking at the main JOSM window the download looks fine - just has an error message that steals focus and won't go away unless you kill JOSM's java process.

This bug effects JOSM 2773 and JOSM 2801 (and probably JOSM 2741 see below for ticket #4307)

I did not suffer this from this bug sometime before JOSM 2773 (I can't be specific which version, but at least 4 or so days before JOSM 2773 was available JOSM-latest was working fine for me then).

A similar bug to this is ticket #4307
But unfortunately it was a poor ticket report.

My system information:
Ubuntu 9.10 x86_64 with latest updates installed,
Sun java 6 run time environment 6-15-1

This bug also effects Ubuntu 9.04 i386 with latest updates installed

This bug also becomes apparent when I have or have no plugins installed (to make sure I even deleted the entire contents of ~/.josm)

Please help as this bug stops me from being able to use JOSM-latest

Crash dump:-

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2010-01-10 02:31:38
Last Changed Author: stoecker
Revision: 2801
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2010-01-09 23:38:57 +0100 (Sat, 09 Jan 2010)
Last Changed Rev: 2801

Memory Usage: 122 MB / 3640 MB (38 MB allocated, but free)
Java version: 1.6.0_15



java.lang.NullPointerException
	at org.openstreetmap.josm.tools.I18n.pluralEval(I18n.java:360)
	at org.openstreetmap.josm.tools.I18n.gettextn(I18n.java:97)
	at org.openstreetmap.josm.tools.I18n.trn(I18n.java:55)
	at org.openstreetmap.josm.gui.layer.OsmDataLayer.getToolTipText(OsmDataLayer.java:258)
	at org.openstreetmap.josm.gui.dialogs.LayerListDialog$LayerListCellRenderer.getListCellRendererComponent(LayerListDialog.java:494)
	at javax.swing.plaf.basic.BasicListUI.updateLayoutState(BasicListUI.java:1349)
	at javax.swing.plaf.basic.BasicListUI.maybeUpdateLayoutState(BasicListUI.java:1299)
	at javax.swing.plaf.basic.BasicListUI.getPreferredSize(BasicListUI.java:566)
	at javax.swing.JComponent.getPreferredSize(JComponent.java:1634)
	at javax.swing.ScrollPaneLayout.layoutContainer(ScrollPaneLayout.java:769)
	at java.awt.Container.layout(Container.java:1421)
	at java.awt.Container.doLayout(Container.java:1410)
	at java.awt.Container.validateTree(Container.java:1507)
	at java.awt.Container.validateTree(Container.java:1513)
	at java.awt.Container.validateTree(Container.java:1513)
	at java.awt.Container.validateTree(Container.java:1513)
	at java.awt.Container.validateTree(Container.java:1513)
	at java.awt.Container.validateTree(Container.java:1513)
	at java.awt.Container.validateTree(Container.java:1513)
	at java.awt.Container.validateTree(Container.java:1513)
	at java.awt.Container.validateTree(Container.java:1513)
	at java.awt.Container.validateTree(Container.java:1513)
	at java.awt.Container.validateTree(Container.java:1513)
	at java.awt.Container.validate(Container.java:1480)
	at javax.swing.RepaintManager.validateInvalidComponents(RepaintManager.java:670)
	at javax.swing.SystemEventQueueUtilities$ComponentWorkRequest.run(SystemEventQueueUtilities.java:127)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

Attachments (1)

screenshot.png (40.4 KB) - added by cam_daw@… 8 years ago.
Screenshot of the crash

Download all attachments as: .zip

Change History (5)

Changed 8 years ago by cam_daw@…

Attachment: screenshot.png added

Screenshot of the crash

comment:1 Changed 8 years ago by anonymous

Resolution: fixed
Status: newclosed

I believe this has just been fixed in r2802.

What language do you have configured?

Please try and reopen this ticket if the issue is still there.

comment:2 Changed 8 years ago by anonymous

Ticket #4307 has been marked as a duplicate of this ticket.

comment:3 Changed 8 years ago by cam_daw@…

Language = English (Australia)
Keyboard layout = USA Dvorak

The language key in JOSM's advanced preferences is blank.

I'll try out r2802 soon and will re-open this ticket if the bugs still exists.

Thanyou :)

comment:4 Changed 8 years ago by cam_daw@…

JOSM r2813 works fine, thanks for the patch :)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.