Modify

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#4275 closed defect (fixed)

terracer gives an error

Reported by: heikki.lehvaslaiho@… Owned by: zerebubuth@…
Priority: blocker Milestone:
Component: Plugin terracer Version: latest
Keywords: Cc:

Description

Terracer plugin was working fine yesterday and I used it heavily. Then unexpectedly I got an error. Unfortunately I did not report that.

Today, there was an updated version of terracer, but it has the same problem. I am happy to test new versions as I would like to finish a set of houses.

Below is the error message:

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2009-12-29 02:32:07
Last Changed Author: stoecker
Revision: 2698
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2009-12-29 00:27:13 +0100 (Tue, 29 Dec 2009)
Last Changed Rev: 2698

Memory Usage: 536 MB / 819 MB (297 MB allocated, but free)
Java version: 1.6.0_0

Dataset consistency test:
No problems found

Plugins: PicLayer,buildings_tools,dataimport,editgpx,openvisible,osmarender,routing,terracer,validator,wmsplugin
Plugin PicLayer Version: 19062
Plugin buildings_tools Version: 28
Plugin dataimport Version: 18071
Plugin editgpx Version: 19052
Plugin openvisible Version: 19004
Plugin osmarender Version: 18971
Plugin routing Version: 19066
Plugin terracer Version: 19129
Plugin validator Version: 19229
Plugin wmsplugin Version: 19240

org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Unable to add primitive {Node id=601486324 version=1 V lat=22.30918440115547,lon=39.096690089711494} to the dataset because its already included

at org.openstreetmap.josm.data.osm.DataSet.addPrimitive(DataSet.java:207)
at org.openstreetmap.josm.command.AddCommand.executeCommand(AddCommand.java:51)
at org.openstreetmap.josm.command.SequenceCommand.executeCommand(SequenceCommand.java:51)
at org.openstreetmap.josm.data.UndoRedoHandler.addNoRedraw(UndoRedoHandler.java:38)
at org.openstreetmap.josm.data.UndoRedoHandler.add(UndoRedoHandler.java:58)
at terracer.TerracerAction.terraceBuilding(TerracerAction.java:185)
at terracer.HouseNumberInputHandler.actionPerformed(HouseNumberInputHandler.java:239)
at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2012)
at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2335)
at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:404)
at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:253)
at java.awt.Component.processMouseEvent(Component.java:6108)
at javax.swing.JComponent.processMouseEvent(JComponent.java:3267)
at java.awt.Component.processEvent(Component.java:5873)
at java.awt.Container.processEvent(Container.java:2105)
at java.awt.Component.dispatchEventImpl(Component.java:4469)
at java.awt.Container.dispatchEventImpl(Container.java:2163)
at java.awt.Component.dispatchEvent(Component.java:4295)
at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4461)
at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4125)
at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4055)
at java.awt.Container.dispatchEventImpl(Container.java:2149)
at java.awt.Window.dispatchEventImpl(Window.java:2478)
at java.awt.Component.dispatchEvent(Component.java:4295)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:604)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:185)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:177)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:138)

Attachments (0)

Change History (2)

comment:1 Changed 8 years ago by bastiK

Resolution: fixed
Status: newclosed

comment:2 Changed 8 years ago by bastiK

Ticket #4379 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain zerebubuth@….
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.