Modify

Opened 8 years ago

Closed 8 years ago

#3449 closed defect (fixed)

action='modified' lost on file reopening

Reported by: Nakor Owned by: team
Priority: blocker Milestone:
Component: Core Version: latest
Keywords: Cc: nakor.wp@…, ruy1802@…

Description

If you modify some ways in a file, save the file, reopen it and try to submit no object is shown as modified in the upload window.

If you deleted some nodes from the way, you get a response from the server that the deleted node is still in use by the modified way.

If you save the OSM file and open it, the action='modify' tags are gone.

Attachments (0)

Change History (9)

comment:1 Changed 8 years ago by Nakor

Cc: nakor.wp@… added
Summary: action='modified'lost on file reopeningaction='modified' lost on file reopening

comment:2 Changed 8 years ago by Nakor

I tried the snapshots to narrow it down: versions up to 2066 are fine version 2075 are higher have the bug.

comment:3 Changed 8 years ago by Bürste

Cc: ruy1802@… added

comment:4 Changed 8 years ago by Bürste

Ticket #3451 has been marked as a duplicate of this ticket.

comment:5 Changed 8 years ago by Gubaer

Resolution: fixed
Status: newclosed

(In [2094]) fixed #3449: action='modified' lost on file reopening

comment:6 Changed 8 years ago by Nakor

Resolution: fixed
Status: closedreopened

comment:7 Changed 8 years ago by Nakor

Bug was reintroduced and is presenr in 2143.

comment:8 Changed 8 years ago by Gubaer

(In [2155]) see #3449: action='modified' lost on file reopening

comment:9 Changed 8 years ago by Gubaer

Resolution: fixed
Status: reopenedclosed

fixed in r2155, somehow the old bug got merged in again

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.