Modify

Opened 8 years ago

Closed 8 years ago

#3353 closed defect (fixed)

OpenStreetBugs plugins damages layer menu

Reported by: anonymous Owned by: team
Priority: blocker Milestone:
Component: Plugin Version: latest
Keywords: OpenStreetBugs Layer Cc:

Description

After updating to JOSM 2005 (from 1997) I get PluginException with validator and also with openstreetbugs when loading data.

Here are the informations:

Path: trunk
URL: http://josm.openstreetmap.de/svn/trunk
Repository Root: http://josm.openstreetmap.de/svn
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Revision: 2005
Node Kind: directory
Last Changed Author: Gubaer
Last Changed Rev: 2005
Last Changed Date: 2009-08-29 15:51:00 +0200 (Sat, 29 Aug 2009)

Memory Usage: 36 MB / 508 MB (8 MB allocated, but free)
Java version: 1.6.0_15

Plugins: remotecontrolvalidatorwmsplugin
Plugin remotecontrol Version: 16965
Plugin validator Version: 17313
Plugin wmsplugin Version: 17343

org.openstreetmap.josm.plugins.PluginException: Ein Fehler ist in dem Plugin validator aufgetreten.

at org.openstreetmap.josm.plugins.PluginProxy.mapFrameInitialized(PluginProxy.java:33)
at org.openstreetmap.josm.plugins.PluginHandler.setMapFrame(PluginHandler.java:192)
at org.openstreetmap.josm.Main.setMapFrame(Main.java:159)
at org.openstreetmap.josm.Main.addLayer(Main.java:216)
at org.openstreetmap.josm.actions.downloadtasks.DownloadOsmTask$Task.finish(DownloadOsmTask.java:128)
at org.openstreetmap.josm.gui.PleaseWaitRunnable$1.run(PleaseWaitRunnable.java:69)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.Dialog$1.run(Unknown Source)
at java.awt.Dialog$3.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.awt.Dialog.show(Unknown Source)
at java.awt.Component.show(Unknown Source)
at java.awt.Component.setVisible(Unknown Source)
at java.awt.Window.setVisible(Unknown Source)
at java.awt.Dialog.setVisible(Unknown Source)
at org.openstreetmap.josm.gui.PleaseWaitDialog.setVisible(PleaseWaitDialog.java:92)
at org.openstreetmap.josm.gui.progress.PleaseWaitProgressMonitor$4.run(PleaseWaitProgressMonitor.java:93)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

Caused by: java.lang.reflect.InvocationTargetException

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.openstreetmap.josm.plugins.PluginProxy.mapFrameInitialized(PluginProxy.java:30)
... 28 more

Caused by: java.lang.NoSuchFieldError: action

at org.openstreetmap.josm.plugins.validator.ValidatorDialog.setVisible(ValidatorDialog.java:121)
at org.openstreetmap.josm.gui.dialogs.ToggleDialog.init(ToggleDialog.java:150)
at org.openstreetmap.josm.gui.dialogs.ToggleDialog.<init>(ToggleDialog.java:111)
at org.openstreetmap.josm.plugins.validator.ValidatorDialog.<init>(ValidatorDialog.java:74)
at org.openstreetmap.josm.plugins.validator.OSMValidatorPlugin.mapFrameInitialized(OSMValidatorPlugin.java:160)
... 33 more

Attachments (0)

Change History (4)

comment:1 Changed 8 years ago by vsandre

Ticket #3354 has been marked as a duplicate of this ticket.

comment:2 Changed 8 years ago by vsandre

Component: Core validatorPlugin
Keywords: OpenStreetBugs Layer added
Priority: normalblocker
Summary: validator and openstreetbugs plugins cause error in JOSM 2005OpenStreetBugs plugins damages layer menu
Version: latest

With the latest JOSM the plugin OpenStreetBugs causes some failures. It is damaging the layer behavior.
The newest validator plugin or the NPE in #3355 are only subsequent errors, because of no layer menu.

comment:3 Changed 8 years ago by vsandre

Problem is fixed in the new Plugin revision 17354, but it needs JOSM r2010.
Damaged OpenStreetBugs plugin is 17035.

comment:4 Changed 8 years ago by stoecker

Resolution: fixed
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.