Modify

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#2993 closed defect (duplicate)

Problem with way splitting

Reported by: michael.letzgus@… Owned by: team
Priority: blocker Milestone:
Component: Core Version:
Keywords: Cc: Gubaer

Description

Hi!
In Version 1807 is a problem with the way splitting ("P") function:
If the way is in a relation it can't be splitted, JOSM reports the attached error message instead.

  1. Open a new layer
  2. Create a 5-node way
  3. Add this way to a new relation of type=route
  4. click apply in the relation editor
  5. select the way an an inner node
  6. press "p"
  7. watch the attached error message ;)

Best regards,

Michael

Path: trunk
URL: http://josm.openstreetmap.de/svn/trunk
Repository Root: http://josm.openstreetmap.de/svn
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Revision: 1807
Node Kind: directory
Last Changed Author: Gubaer
Last Changed Rev: 1807
Last Changed Date: 2009-07-19 00:06:29 +0200 (Sun, 19 Jul 2009)

Memory Usage: 105 MB / 910 MB (47 MB allocated, but free)
Java version: 1.6.0_14

Plugins: Create_grid_of_ways
DirectUpload
Intersect_way
PicLayer
buildings_tools
editgpx
measurement
multipoly
openstreetbugs
remotecontrol
routing
tageditor
tagging-preset-tester
terracer
usertools
utilsplugin
validator
waydownloader
wmsplugin
Plugin Create_grid_of_ways Version: 16290
Plugin DirectUpload Version: 15828
Plugin Intersect_way Version: 12781
Plugin PicLayer Version: 16302
Plugin buildings_tools Version: 19
Plugin editgpx Version: 16294
Plugin measurement Version: 16317
Plugin multipoly Version: ${version.entry.commit.revision}
Plugin openstreetbugs Version: 16564
Plugin remotecontrol Version: 16290
Plugin routing Version: 16409
Plugin tageditor Version: 15707
Plugin tagging-preset-tester Version: 14015
Plugin terracer Version: 16162
Plugin usertools Version: 14125
Plugin utilsplugin Version: 16290
Plugin validator Version: 16439
Plugin waydownloader Version: 16290
Plugin wmsplugin Version: 16442

java.lang.NullPointerException

at org.openstreetmap.josm.actions.SplitWayAction.splitWay(SplitWayAction.java:287)
at org.openstreetmap.josm.actions.SplitWayAction.actionPerformed(SplitWayAction.java:159)
at javax.swing.SwingUtilities.notifyAction(Unknown Source)
at javax.swing.JComponent.processKeyBinding(Unknown Source)
at javax.swing.KeyboardManager.fireBinding(Unknown Source)
at javax.swing.KeyboardManager.fireKeyboardAction(Unknown Source)
at javax.swing.JComponent.processKeyBindingsForAllComponents(Unknown Source)
at javax.swing.JComponent.processKeyBindings(Unknown Source)
at javax.swing.JComponent.processKeyEvent(Unknown Source)
at java.awt.Component.processEvent(Unknown Source)
at java.awt.Container.processEvent(Unknown Source)
at java.awt.Component.dispatchEventImpl(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.KeyboardFocusManager.redispatchEvent(Unknown Source)
at java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent(Unknown Source)
at java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent(Unknown Source)
at java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(Unknown Source)
at java.awt.DefaultKeyboardFocusManager.dispatchEvent(Unknown Source)
at java.awt.Component.dispatchEventImpl(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Window.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (3)

comment:1 Changed 9 years ago by anonymous

Ticket #2992 has been marked as a duplicate of this ticket.

comment:2 Changed 9 years ago by Gubaer

Cc: Gubaer added
Resolution: duplicate
Status: newclosed

fixed in r1809

comment:3 Changed 9 years ago by Gubaer

Closed as duplicate of #2975.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.