Modify

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#2975 closed defect (fixed)

Error message while trying to split way with relation without role

Reported by: ruy1802@… Owned by: team
Priority: blocker Milestone:
Component: Core Version: latest
Keywords: Cc: Gubaer

Description

Path: trunk
URL: http://josm.openstreetmap.de/svn/trunk
Repository Root: http://josm.openstreetmap.de/svn
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Revision: 1799
Node Kind: directory
Last Changed Author: Gubaer
Last Changed Rev: 1799
Last Changed Date: 2009-07-16 19:23:24 +0200 (Thu, 16 Jul 2009)

Memory Usage: 32 MB / 508 MB (7 MB allocated, but free)
Java version: 1.6.0_03

Plugins: ImageWayPoint
PicLayer
editgpx
lakewalker
livegps
multipoly
nearclick
openstreetbugs
openvisible
remotecontrol
surveyor
tageditor
tagging-preset-tester
terracer
usertools
utilsplugin
validator
waydownloader
wmsplugin
Plugin ImageWayPoint Version: 16294
Plugin PicLayer Version: 16302
Plugin editgpx Version: 16294
Plugin lakewalker Version: 15961
Plugin livegps Version: 16294
Plugin multipoly Version: ${version.entry.commit.revision}
Plugin nearclick Version: 14015
Plugin openstreetbugs Version: 16294
Plugin openvisible Version: 15707
Plugin remotecontrol Version: 16290
Plugin tageditor Version: 15707
Plugin tagging-preset-tester Version: 14015
Plugin terracer Version: 16162
Plugin usertools Version: 14125
Plugin utilsplugin Version: 16290
Plugin validator Version: 16439
Plugin waydownloader Version: 16290
Plugin wmsplugin Version: 16442
Plugin surveyor Version: 16409

java.lang.NullPointerException

at org.openstreetmap.josm.actions.SplitWayAction.splitWay(SplitWayAction.java:287)
at org.openstreetmap.josm.actions.SplitWayAction.actionPerformed(SplitWayAction.java:159)
at javax.swing.SwingUtilities.notifyAction(Unknown Source)
at javax.swing.JComponent.processKeyBinding(Unknown Source)
at javax.swing.KeyboardManager.fireBinding(Unknown Source)
at javax.swing.KeyboardManager.fireKeyboardAction(Unknown Source)
at javax.swing.JComponent.processKeyBindingsForAllComponents(Unknown Source)
at javax.swing.JComponent.processKeyBindings(Unknown Source)
at javax.swing.JComponent.processKeyEvent(Unknown Source)
at java.awt.Component.processEvent(Unknown Source)
at java.awt.Container.processEvent(Unknown Source)
at java.awt.Component.dispatchEventImpl(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.KeyboardFocusManager.redispatchEvent(Unknown Source)
at java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent(Unknown Source)
at java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent(Unknown Source)
at java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(Unknown Source)
at java.awt.DefaultKeyboardFocusManager.dispatchEvent(Unknown Source)
at java.awt.Component.dispatchEventImpl(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Window.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (5)

comment:1 Changed 9 years ago by ruy1802@…

seems to happend only if a relation had this way just got as new member

comment:2 Changed 9 years ago by Gubaer

Cc: Gubaer added
Resolution: fixed
Status: newclosed

fixed in r1809

comment:3 Changed 9 years ago by Gubaer

Ticket #2981 has been marked as a duplicate of this ticket.

comment:4 Changed 9 years ago by Gubaer

Ticket #2993 has been marked as a duplicate of this ticket.

comment:5 Changed 9 years ago by jttt

Ticket #3001 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.