Modify

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#1901 closed defect (fixed)

JOSM shows backtrace on fresh install (without plugins) in [1183]

Reported by: avarab@… Owned by: framm
Priority: blocker Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

Steps to reproduce:

  1. mv ~/.josm ~/.josm.old
  2. start josm
  3. Get this backtrace after the splash screen:

Development version. Unknown revision.
java.lang.NoSuchMethodError: org.openstreetmap.josm.data.Preferences.put(Ljava/lang/String;Ljava/lang/String;)V

at org.openstreetmap.josm.tools.PlatformHookUnixoid.initShortcutGroups(PlatformHookUnixoid.java:33)
at org.openstreetmap.josm.tools.Shortcut.doInit(Shortcut.java:277)
at org.openstreetmap.josm.tools.Shortcut.registerShortcut(Shortcut.java:393)
at org.openstreetmap.josm.tools.Shortcut.registerShortcut(Shortcut.java:383)
at org.openstreetmap.josm.actions.NewAction.<init>(NewAction.java:17)
at org.openstreetmap.josm.gui.MainMenu.<init>(MainMenu.java:78)
at org.openstreetmap.josm.Main.<init>(Main.java:201)
at org.openstreetmap.josm.gui.MainApplication.<init>(MainApplication.java:49)
at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:220)

Attachments (0)

Change History (2)

comment:1 Changed 9 years ago by anonymous

Resolution: fixed
Status: newclosed

You did your own compiled version I assume. Do a clean (e.g. "ant clean") and recompile.

Reopen if this does not help.

If this is a packaged version (Ubuntu) tell the maintainer of the package about.
It seems the Java builds sometimes have problems with dependency tracking and do not recompile everything which is needed.

comment:2 Changed 9 years ago by avarab@…

I can't reproduce it after a build with ant clean && ant dist

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain framm.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.