Modify

Opened 9 years ago

Closed 9 years ago

#1593 closed defect (duplicate)

bug in open a permalink

Reported by: musarati Owned by: framm
Priority: blocker Milestone:
Component: unspecified Version:
Keywords: Cc:

Description

Path: trunk
URL: http://josm.openstreetmap.de/svn/trunk
Repository Root: http://josm.openstreetmap.de/svn
copy a permantment OSM link to the "open" box and klick ok...
wait some seconds...

used link: http://www.openstreetmap.com/?lat=49.222&lon=12.6941&zoom=13&layers=B000FTF

Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Revision: 998
Node Kind: directory
Last Changed Author: stoecker
Last Changed Rev: 998
Last Changed Date: 2008-09-20 22:48:57 +0200 (Sat, 20 Sep 2008)

java.lang.RuntimeException: java.lang.reflect.InvocationTargetException

at org.openstreetmap.josm.gui.PleaseWaitRunnable.closeDialog(PleaseWaitRunnable.java:146)
at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:95)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:885)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:907)
at java.lang.Thread.run(Thread.java:619)

Caused by: java.lang.reflect.InvocationTargetException

at java.awt.EventQueue.invokeAndWait(EventQueue.java:997)
at org.openstreetmap.josm.gui.PleaseWaitRunnable.closeDialog(PleaseWaitRunnable.java:142)
... 4 more

Caused by: org.openstreetmap.josm.plugins.PluginException: Ein Fehler ist in dem Plugin validator aufgetreten.

at org.openstreetmap.josm.plugins.PluginProxy.mapFrameInitialized(PluginProxy.java:33)
at org.openstreetmap.josm.Main.setMapFrame(Main.java:152)
at org.openstreetmap.josm.Main.addLayer(Main.java:309)
at org.openstreetmap.josm.actions.NewAction.actionPerformed(NewAction.java:21)
at org.openstreetmap.josm.Main.editLayer(Main.java:321)
at org.openstreetmap.josm.actions.downloadtasks.DownloadOsmTask$Task.finish(DownloadOsmTask.java:49)
at org.openstreetmap.josm.gui.PleaseWaitRunnable$4.run(PleaseWaitRunnable.java:128)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:199)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:273)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:183)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:177)
at java.awt.Dialog$1.run(Dialog.java:1039)
at java.awt.Dialog$3.run(Dialog.java:1091)
at java.security.AccessController.doPrivileged(Native Method)
at java.awt.Dialog.show(Dialog.java:1089)
at java.awt.Component.show(Component.java:1419)
at java.awt.Component.setVisible(Component.java:1372)
at java.awt.Window.setVisible(Window.java:801)
at java.awt.Dialog.setVisible(Dialog.java:979)
at org.openstreetmap.josm.gui.PleaseWaitRunnable$3.run(PleaseWaitRunnable.java:78)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:273)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:183)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:173)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:168)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:160)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:121)

Caused by: java.lang.reflect.InvocationTargetException

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.openstreetmap.josm.plugins.PluginProxy.mapFrameInitialized(PluginProxy.java:30)
... 28 more

Caused by: java.lang.NoSuchMethodError: org.openstreetmap.josm.data.osm.visitor.SimplePaintVisitor.getPreferencesColor(Ljava/lang/String;Ljava/awt/Color;)Ljava/awt/Color;

at org.openstreetmap.josm.plugins.validator.Severity.<clinit>(Severity.java:10)
at org.openstreetmap.josm.plugins.validator.ErrorLayer.getToolTipText(ErrorLayer.java:92)
at org.openstreetmap.josm.gui.dialogs.LayerListDialog$1.getListCellRendererComponent(LayerListDialog.java:174)
at javax.swing.plaf.basic.BasicListUI.updateLayoutState(BasicListUI.java:1342)
at javax.swing.plaf.basic.BasicListUI.maybeUpdateLayoutState(BasicListUI.java:1292)
at javax.swing.plaf.basic.BasicListUI$Handler.valueChanged(BasicListUI.java:2605)
at javax.swing.DefaultListSelectionModel.fireValueChanged(DefaultListSelectionModel.java:167)
at javax.swing.DefaultListSelectionModel.fireValueChanged(DefaultListSelectionModel.java:147)
at javax.swing.DefaultListSelectionModel.fireValueChanged(DefaultListSelectionModel.java:194)
at javax.swing.DefaultListSelectionModel.changeSelection(DefaultListSelectionModel.java:388)
at javax.swing.DefaultListSelectionModel.changeSelection(DefaultListSelectionModel.java:398)
at javax.swing.DefaultListSelectionModel.setSelectionInterval(DefaultListSelectionModel.java:442)
at javax.swing.JList.setSelectedIndex(JList.java:2179)
at javax.swing.JList.setSelectedValue(JList.java:2295)
at org.openstreetmap.josm.gui.dialogs.LayerListDialog.activeLayerChange(LayerListDialog.java:314)
at org.openstreetmap.josm.gui.MapView.setActiveLayer(MapView.java:383)
at org.openstreetmap.josm.gui.MapView.addLayer(MapView.java:179)
at org.openstreetmap.josm.Main.addLayer(Main.java:314)
at org.openstreetmap.josm.plugins.validator.OSMValidatorPlugin.mapFrameInitialized(OSMValidatorPlugin.java:83)
... 33 more

Attachments (0)

Change History (1)

comment:1 Changed 9 years ago by anonymous

Resolution: duplicate
Status: newclosed

Update the Validator plugin. Duplicate of #1430.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain framm.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.