Modify

Opened 3 weeks ago

Closed 2 weeks ago

#15721 closed defect (fixed)

documentation of TODO plugin

Reported by: mkoniecz Owned by: team
Priority: normal Milestone:
Component: Plugin todo Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. open plugin list
  2. filter by TODO
  3. follow "More info" link

What is the expected result?

Documentation page links code and page to report issues

What happens instead?

Only dead original repo was linked ( https://github.com/Gnonthgol/JOSM-todo ) and page instructed to report problems and make suggestion on a wiki page itself.

Please provide any additional information below. Attach a screenshot if possible.

I fixed reported problem on page, linked https://github.com/JOSM/todo repo, but I am unsure what should be specified as place for "Bugs and feature requests". I see "plugin todo" as component on this bugtracker so I guess that it is OK to report bugs here.

Are feature requests for TODO plugin also welcomed on this bugtracker?

Is there any misleading info in that was changed during my attempts to fix the outdated documentation- see https://wiki.openstreetmap.org/w/index.php?title=JOSM%2FPlugins%2FTODO_list&type=revision&diff=1542492&oldid=1534940 ?

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-12-31 03:09:43 +0100 (Sun, 31 Dec 2017)
Build-Date:2017-12-31 02:33:46
Revision:13265
Relative:URL: ^/trunk

Identification: JOSM/1.5 (13265 en) Linux Ubuntu 16.04.3 LTS
Memory Usage: 944 MB / 944 MB (122 MB allocated, but free)
Java version: 1.8.0_151-b12, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: :0.0 1920x1080
Maximum Screen Size: 1920x1080
Dataset consistency test: No problems found

Plugins:
+ OpeningHoursEditor (33876)
+ buildings_tools (33735)
+ continuosDownload (68)
+ imagery_offset_db (33774)
+ reverter (33865)
+ todo (30303)

Last errors/warnings:
- W: java.net.SocketTimeoutException: Read timed out
- W: java.net.SocketTimeoutException: Read timed out
- W: java.net.SocketTimeoutException: Read timed out
- W: java.net.SocketTimeoutException: Read timed out
- W: java.net.SocketTimeoutException: Read timed out
- E: Error header: Precondition failed: The relation 3092480 is used in relation 3099551.
- E: org.openstreetmap.josm.io.OsmApiException: ResponseCode=412, Error Header=<Precondition failed: The relation 3092480 is used in relation 3099551.>
- E: Object still in use - <html><strong>Failed</strong> to delete <strong>relation 3092480</strong>. It is still referred to by relation 3099551.<br>Please load the relation, remove the reference to the relation, and upload again.<br><br>Click <strong>Prepare conflict resolution</strong> to load them now.<br>If necessary JOSM will create conflicts which you can resolve in the Conflict Resolution Dialog.</html>
- E: org.openstreetmap.josm.io.OsmTransferException: org.openstreetmap.josm.io.IllegalDataException: Line 1 column 1: Content is not allowed in prolog.. Cause: org.openstreetmap.josm.io.IllegalDataException: Line 1 column 1: Content is not allowed in prolog.. Cause: javax.xml.stream.XMLStreamException: ParseError at [row,col]:[1,1]
- E: Illegal Data - <html>Failed to download data. Its format is either unsupported, ill-formed, and/or inconsistent.<br><br>Details (untranslated): Line 1 column 1: Content is not allowed in prolog.</html>

Attachments (0)

Change History (6)

comment:1 Changed 3 weeks ago by Don-vip

Component: unspecifiedPlugin todo

you can either report issues here or on Github, as you wish

comment:2 Changed 3 weeks ago by anonymous

So https://github.com/Gnonthgol/JOSM-todo is monitored by JOSM developers?

comment:3 Changed 2 weeks ago by Don-vip

comment:4 Changed 2 weeks ago by mkoniecz

https://github.com/JOSM/todo has disabled (or not enabled) creation of issues. Is it intentional?

comment:5 Changed 2 weeks ago by Don-vip

Ah, then here it's perfect :) Simpler to have all of them at a single place.

comment:6 Changed 2 weeks ago by mkoniecz

Resolution: fixed
Status: newclosed

Thanks, wiki page now seems to be correct.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.