Modify

Opened 2 weeks ago

Closed 11 days ago

#15718 closed defect (fixed)

Validator wrong message, missing tag - sport without physical feature

Reported by: dieterdreist Owned by: dieterdreist
Priority: trivial Milestone: 18.01
Component: Core validator Version: latest
Keywords: template_report leisure sport Cc:

Description

What steps will reproduce the problem?

  1. create new object with sport=* and an adhoc-leisure object
  2. validate

What is the expected result?

no warning, or maybe a different warning:
"missing tag - sport without known physical feature"
(because there is a leisure=* object, but maybe generally a "known" would be better).

What happens instead?

missleading warning: "missing tag - sport without physical feature"

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-01-02 00:31:23 +0100 (Tue, 02 Jan 2018)
Build-Date:2018-01-02 02:33:50
Revision:13271
Relative:URL: ^/trunk

Identification: JOSM/1.5 (13271 en) Mac OS X 10.13.2
OS Build number: Mac OS X 10.13.2 (17C88)
Memory Usage: 696 MB / 1820 MB (282 MB allocated, but free)
Java version: 1.8.0_144-b01, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: Display 188875522 1920x1080, Display 458628992 1920x1080
Maximum Screen Size: 1920x1080
VM arguments: [-Dsun.java2d.opengl=true]
Dataset consistency test: No problems found

Plugins:
+ ColorPlugin (1511895663)
+ Create_grid_of_ways (33856)
+ ImportImagePlugin (33563)
+ PicLayer (33822)
+ ShapeTools (1230)
+ apache-commons (33668)
+ buildings_tools (33735)
+ editgpx (33782)
+ ejml (32680)
+ fieldpapers (v0.4.3)
+ geochat (33796)
+ geojson (73)
+ geotools (33958)
+ imagery_offset_db (33774)
+ jts (32699)
+ log4j (32699)
+ mbtiles (a3e491d)
+ measurement (33760)
+ o5m (33566)
+ osmarender (33916)
+ pbf (33568)
+ photo_geotagging (33967)
+ reltoolbox (33708)
+ reverter (33865)
+ undelete (33835)
+ utilsplugin2 (33742)

Last errors/warnings:
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet

Attachments (0)

Change History (6)

comment:1 Changed 2 weeks ago by mkoniecz

"and an adhoc-leisure object"

What value of leisure tag was used? Maybe it can be additionally fixed by adding it to list of known ones.

comment:2 Changed 2 weeks ago by Don-vip

Owner: changed from team to dieterdreist
Status: newneedinfo

comment:3 Changed 11 days ago by Don-vip

up. What's the leisure value?

comment:4 Changed 11 days ago by dieterdreist

in this case it is “ramp” (not used yet), an isolated skateboarding ramp, not a “skatepark”
I didn’t like to tag it “pitch”, because it’s not a pitch.

comment:5 Changed 11 days ago by Don-vip

Keywords: leisure sport added
Milestone: 18.01

comment:6 Changed 11 days ago by Don-vip

Resolution: fixed
Status: needinfoclosed

In 13291/josm:

fix #15718 - allow all leisure tags for "sport without physical feature" warning

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain dieterdreist.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.