Modify

Opened 2 months ago

Closed 2 weeks ago

#15681 closed defect (duplicate)

Unable to merge two closed ways with merge-overlap

Reported by: ViriatoLusitano Owned by: team
Priority: normal Milestone:
Component: Plugin merge-overlap Version: latest
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Download attached file
  2. Select both closed ways
  3. Press Ctrl+Alt+O to merge

What is the expected result?

Should merge, leaving the mid section way separated from the rest.

What happens instead?

Doesn't merge.

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-12-18 23:25:29 +0100 (Mon, 18 Dec 2017)
Build-Date:2017-12-19 02:58:35
Revision:13226
Relative:URL: ^/trunk

Identification: JOSM/1.5 (13226 pt) Windows 10 64-Bit
OS Build number: Windows 10 Pro 1703 (15063)
Memory Usage: 1302 MB / 3641 MB (663 MB allocated, but free)
Java version: 1.8.0_121-b13, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 2560x1080, \Display1 1920x1080
Maximum Screen Size: 2560x1080
Dataset consistency test: No problems found

Plugins:
+ FastDraw (33731)
+ FixAddresses (33718)
+ PicLayer (33822)
+ SimplifyArea (33918)
+ apache-commons (33668)
+ buildings_tools (33735)
+ download_along (33710)
+ editgpx (33782)
+ ejml (32680)
+ geotools (33930)
+ graphview (33938)
+ jts (32699)
+ log4j (32699)
+ measurement (33760)
+ merge-overlap (33848)
+ opendata (33791)
+ pdfimport (33579)
+ reverter (33865)
+ tageditor (33806)
+ tagging-preset-tester (33898)
+ terracer (33839)
+ turnlanes-tagging (260)
+ turnrestrictions (33780)
+ undelete (33835)
+ utilsplugin2 (33742)

Tagging presets:
+ C:\OpenStreetMap\Portugal_Administrative_Mapping.xml
+ https://raw.githubusercontent.com/yopaseopor/traffic_signs_preset_JOSM/master/PT.zip

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Enhanced_Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1

Last errors/warnings:
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: Unable to use English input method
- E: Handled by bug report queue: java.lang.NullPointerException


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (19) of main
java.lang.NullPointerException
	at org.openstreetmap.josm.gui.conflict.tags.RelationMemberConflictResolverModel.prepareDefaultRelationDecisions(RelationMemberConflictResolverModel.java:227)
	at org.openstreetmap.josm.gui.conflict.tags.CombinePrimitiveResolverDialog.prepareDefaultDecisions(CombinePrimitiveResolverDialog.java:311)
	at org.openstreetmap.josm.gui.conflict.tags.CombinePrimitiveResolverDialog.prepareDefaultDecisions(CombinePrimitiveResolverDialog.java:301)
	at mergeoverlap.MergeOverlapAction.combineWaysWorker(MergeOverlapAction.java:378)
	at mergeoverlap.MergeOverlapAction.actionPerformed(MergeOverlapAction.java:207)
	at javax.swing.SwingUtilities.notifyAction(Unknown Source)
	at javax.swing.JComponent.processKeyBinding(Unknown Source)
	at javax.swing.KeyboardManager.fireBinding(Unknown Source)
	at javax.swing.KeyboardManager.fireKeyboardAction(Unknown Source)
	at javax.swing.JComponent.processKeyBindingsForAllComponents(Unknown Source)
	at javax.swing.JComponent.processKeyBindings(Unknown Source)
	at javax.swing.JComponent.processKeyEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.KeyboardFocusManager.redispatchEvent(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.dispatchEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (1)

Merge Error.osm (5.6 KB) - added by ViriatoLusitano 2 months ago.

Download all attachments as: .zip

Change History (2)

Changed 2 months ago by ViriatoLusitano

Attachment: Merge Error.osm added

comment:1 Changed 2 weeks ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #14971.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.