Modify

Opened 2 weeks ago

Closed 2 weeks ago

Last modified 13 days ago

#15627 closed defect (fixed)

JOSM sometimes seems to forget the preset values for tag key highway

Reported by: GerdP Owned by: team
Priority: major Milestone: 17.12
Component: Core Version:
Keywords: template_report regression Cc:

Description

What steps will reproduce the problem?

  1. Edit a while.
  2. Try to add a tag like highway=residential to a way by typing Alt+A and the key highway and the val res.

What is the expected result?

Auto complete should change res to residential.

What happens instead?

Nothing from auto complete. When I click on the down arrow on the right of the edit field it shows an empty list.

Please provide any additional information below. Attach a screenshot if possible.

Don't know for sure what triggers this. Sometimes it happens a few minutes after starting to edit.
Sometimes it disappears again and appears again later.
I did not see this with other tags like natural or landuse.
It seems I am not the only one having this problem because I sometimes see tags with typos like unclassifed or residental created with JOSM and also ones with u or un.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-11-26 14:31:59 +0100 (Sun, 26 Nov 2017)
Build-Date:2017-11-26 13:34:54
Revision:13170
Relative:URL: ^/trunk

Identification: JOSM/1.5 (13170 en) Windows 10 64-Bit
OS Build number: Windows 10 Home 1703 (15063)
Memory Usage: 535 MB / 4551 MB (332 MB allocated, but free)
Java version: 1.8.0_151-b12, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1080
Maximum Screen Size: 1920x1080
Dataset consistency test: No problems found

Plugins:
+ FastDraw (33731)
+ apache-commons (33668)
+ buildings_tools (33735)
+ download_along (33710)
+ ejml (32680)
+ geotools (33930)
+ jts (32699)
+ measurement (33760)
+ o5m (33566)
+ opendata (33791)
+ pbf (33568)
+ poly (33570)
+ reverter (33865)
+ utilsplugin2 (33742)

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1

Last errors/warnings:
- W: java.net.UnknownHostException: cyberjapandata.gsi.go.jp
- W: java.net.UnknownHostException: cyberjapandata.gsi.go.jp
- W: java.net.UnknownHostException: cyberjapandata.gsi.go.jp
- W: java.net.UnknownHostException: cyberjapandata.gsi.go.jp
- W: java.net.UnknownHostException: cyberjapandata.gsi.go.jp
- W: java.net.UnknownHostException: cyberjapandata.gsi.go.jp
- W: java.net.UnknownHostException: api.openstreetmap.org
- E: java.net.UnknownHostException: api.openstreetmap.org
- W: org.openstreetmap.josm.io.OsmTransferException: Could not connect to the OSM server. Please check your internet connection.. Cause: java.net.UnknownHostException: api.openstreetmap.org
- E: Handled by bug report queue: java.util.NoSuchElementException

Attachments (0)

Change History (8)

comment:1 Changed 2 weeks ago by Don-vip

Keywords: regression added
Milestone: 17.12
Priority: normalmajor

Confirmed. Seems to work fine in r13053 but broken in r13170

EDIT: regression introduced in r13137:13143

EDIT: regression of r13139 / #13747

Last edited 2 weeks ago by Don-vip (previous) (diff)

comment:2 Changed 2 weeks ago by Don-vip

Resolution: fixed
Status: newclosed

In 13190/josm:

fix #15627 - autocompletion values not correctly reset on change of focus (regression from r13139)

comment:3 Changed 2 weeks ago by Klumbumbus

Hm, I would have said new stable hotfix, but thats not really possible atm due to #15310, right?

comment:4 Changed 2 weeks ago by Don-vip

Almost all plugins are updated now. We could release an hotfix soon. In the meanwhile, can you please test extensively the autocompletion/focus/tagging UI? To be sure everything's fine now.

comment:5 Changed 2 weeks ago by GerdP

I've installed r13190 now and did not see the problem in my last edit session. I still have the problem that some JOSM dialogs sometimes stop to react on keys like tab while mouse clicks still work. Or maybe this was gone with r13170 is now back again?

comment:6 in reply to:  5 Changed 13 days ago by Don-vip

Replying to GerdP:

I still have the problem that some JOSM dialogs sometimes stop to react on keys like tab while mouse clicks still work. Or maybe this was gone with r13170 is now back again?

You'll have to be more precise than that. Which dialog(s)?

comment:7 Changed 13 days ago by GerdP

OK, for example the add tag dialog (Alt+A) sometimes only reacts on mouse clicks, also the layers dialog sometimes doesn't react on Space to toggle the visibility of a layer. This behaviour also seems to depend on the change of focus to another program.

comment:8 Changed 13 days ago by stoecker

I don't thing this qualifies as hotfix in the current situation... Chances are much higher that a hotfix breaks more than it fixes.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.