Modify

Opened 2 weeks ago

Closed 2 weeks ago

Last modified 9 days ago

#15619 closed task (fixed)

double imagery entry

Reported by: Klumbumbus Owned by: nkamapper
Priority: normal Milestone:
Component: External imagery source Version:
Keywords: Cc:

Description

You changed/added some imageries today. For norway there is the same url in two different entries. Could you please check this? Thanks.

http://openwms.statkart.no/skwms1/wms.vegnett?FORMAT=image/png&TRANSPARENT=TRUE&VERSION=1.1.1&SERVICE=WMS&REQUEST=GetMap&LAYERS=all&STYLES=&SRS={proj}&WIDTH={width}&HEIGHT={height}&BBOX={bbox}

in Kartverket Sjøkart and Kartverket Vegnett

Attachments (0)

Change History (26)

comment:1 Changed 2 weeks ago by nkamapper

Thank you, fixed.

comment:2 Changed 2 weeks ago by nkamapper

Resolution: fixed
Status: assignedclosed

comment:3 Changed 2 weeks ago by Klumbumbus

Thanks for your additions to the maps pages. Please keep the following in mind:

  • always make sure that the OSM community is allowed to trace from the source
  • use english names only, the translation is done via Launchpad
  • for TMS sources use {zoom} instead of {z}
  • for sources based on OSM data we usually use <valid-georeference>true</valid-georeference> to suppress the warning message about imagery offset.
  • please use shapes instead of only bounds. This is important because sources are automatically added to the imagery menu when the mapview is within the area of a source. So with large bounding boxes, you get the source suggested although it is maybe not available in this area. I created an example for the source at Maps/Finland. It is sufficient to make the shape this rough like in the example, but can be finer too. To easily create the shape code install the Imagery-XML-Bounds Plugin, create the boundary way in josm, right click on it in the selection dialog and click on XML Imagery bounds. Then you can copy the bounds and shape code from there.

comment:4 in reply to:  3 ; Changed 13 days ago by nkamapper

Thank you for your helpful comments.

  • always make sure that the OSM community is allowed to trace from the source

Done, they are according to our local wiki and with permission from the data owner. I made one change after further verification with the community over the weekend.

  • use english names only, the translation is done via Launchpad

Ok, thank you for clarifying, and I will provide translations there. The lang="no" names does not work in JOSM at my end anyway.

  • for TMS sources use {zoom} instead of {z}

Thank you for fixing one omission.

  • for sources based on OSM data we usually use <valid-georeference>true</valid-georeference> to suppress the warning message about imagery offset.

I have only set to true for imagery directly derived from OSM or from the National Mapping Authority (Kartverket), which does not have any offset, so should be ok.

  • please use shapes instead of only bounds. This is important because sources are automatically added to the imagery menu when the mapview is within the area of a source. So with large bounding boxes, you get the source suggested although it is maybe not available in this area. I created an example for the source at Maps/Finland. It is sufficient to make the shape this rough like in the example, but can be finer too. To easily create the shape code install the Imagery-XML-Bounds Plugin, create the boundary way in josm, right click on it in the selection dialog and click on XML Imagery bounds. Then you can copy the bounds and shape code from there.

Ok, I will produce the shapes.
This functionality has never worked in JOSM at any of my three computers. I always get the entire global list. Not sure why.

comment:5 in reply to:  4 Changed 13 days ago by Don-vip

Replying to nkamapper:

Ok, I will produce the shapes.
This functionality has never worked in JOSM at any of my three computers. I always get the entire global list. Not sure why.

I'm the maintainer of this plugin, could you please create a new bug report with a step-by-step description? I'll have a look.

comment:6 in reply to:  4 ; Changed 13 days ago by stoecker

Replying to nkamapper:

  • use english names only, the translation is done via Launchpad

Ok, thank you for clarifying, and I will provide translations there. The lang="no" names does not work in JOSM at my end anyway.

Well, Norsk is below the minimum limit, so translations are ignored ATM (until someone improves Norsk translation essentially).

  • for TMS sources use {zoom} instead of {z}

Thank you for fixing one omission.

We get warnings about these :-)

Ok, I will produce the shapes.
This functionality has never worked in JOSM at any of my three computers. I always get the entire global list. Not sure why.

You always see them all in the settings (with bounds shown in the map). But the entries auto-added to the imagery menu during runtime rely on the bounds.

comment:7 in reply to:  6 Changed 13 days ago by nkamapper

You always see them all in the settings (with bounds shown in the map). But the entries auto-added to the imagery menu during runtime rely on the bounds.

Ok, so no bug. Just have not seen them in the menu until now because the list have been empty here in the North :-)

comment:8 Changed 13 days ago by stoecker

P.S. If you can encourage Norsk users (including yourself) to complete the translation we are happy to re-add the language. It already was in JOSM in the past, but was unmaintained and falling back. Its a big task for a single person, but even that has been done before (Japanese if I remember: 100% by one guy in about 10 days).

comment:9 in reply to:  8 Changed 13 days ago by stoecker

Replying to stoecker:

P.S. If you can encourage Norsk users (including yourself) to complete the translation we are happy to re-add the language. It already was in JOSM in the past, but was unmaintained and falling back. Its a big task for a single person, but even that has been done before (Japanese if I remember: 100% by one guy in about 10 days).

No, I mixed that up. That was Turkish. Norsk is still included as "Norsk Bokmål" (nb). I don't know differences between no and nb. Anyway "nb" also needs updates (or "no" :-)

comment:10 Changed 13 days ago by Don-vip

It's often useful to remind local mailing lists that JOSM requires translation. I did that a few weeks ago on French mailing list and a single guy translated the ~500 missing strings, we're now at 100% for the first time in many years :)

comment:11 in reply to:  4 Changed 13 days ago by Klumbumbus

Replying to nkamapper:

I have only set to true for imagery directly derived from OSM or from the National Mapping Authority (Kartverket), which does not have any offset, so should be ok.

Right. It seems I overlooked that attribute.

comment:12 Changed 13 days ago by Klumbumbus

After you made changes to the maps entries you can have a look at ImageryCompare. If there are red entries in the large list then much likely something was wrong (e.g. z instead of zoom or discrepancies between bounds and shape).

comment:13 Changed 13 days ago by nkamapper

Now I have done the translations. Not showing up until tomorrow if I have understood it correctly.
There is one entry with red line - I adjusted the English name and description. Not sure why it is red.

comment:14 Changed 13 days ago by Klumbumbus

The page also compares the entries with them at https://github.com/osmlab/editor-layer-index. You changed one of the imagico entries. Please don't change them. There are a lot of them and all follow the same naming and description format, which is directly provided by http://www.imagico.de/.

comment:15 Changed 13 days ago by nkamapper

Ok, will revert it.

comment:16 Changed 13 days ago by nkamapper

Done, and ok/not red it seems.

comment:17 Changed 11 days ago by nkamapper

I have updated shapes and they seem to be ok.
I have also made translations for Norwegian Bokmål in Launchpad, however, they are not showing up in JOSM, which is also set to Norwegian Bokmål, even after 1-3 days. Is there a long lag after Launchpad updates?

comment:18 in reply to:  17 ; Changed 11 days ago by stoecker

I have also made translations for Norwegian Bokmål in Launchpad, however, they are not showing up in JOSM, which is also set to Norwegian Bokmål, even after 1-3 days. Is there a long lag after Launchpad updates?

Yes. Sorry. Although they are server related these texts are actually kept in the normal JOSM translation. They will only be updated with next core I18n update. That's sub-optimal, but not so easy changeable ATM.

comment:19 in reply to:  18 Changed 11 days ago by Klumbumbus

Replying to stoecker:

next core I18n update

(Which means in practice much likely shortly before the next stable release at the end of the month.)

comment:20 Changed 10 days ago by nkamapper

Ok, I understand. I actually think it would be a lot easier to provide the Norwegian names for the maps with the lang 'nb' option instead of using Launchpad. Syncing is quite cumbersome - a new translation must be provided each time the English version has been slightly altered. I do not think anyone would be interested in providing other translations for Norway anyway. In Central Europe and elsewhere the situation could be different of course, so Launchpad in general is more flexible, however perhaps not necessary in this case.
I will anyway look into the other missing JOSM translations for the application.

comment:21 Changed 10 days ago by stoecker

You can do both if you want. The automatic way will be there, but local provided translations also. There is no sync in any way ATM (and the two could even be different). While syncing would be possible it was not worth the effort to develop the necessary tools. So until a big demand comes up we have to live with the current situation ;-)

comment:22 Changed 10 days ago by Klumbumbus

This <description lang="en">Trails from the Norwegian database of "Tur og Friluftsruter". Selectable categories for foot, bike and ski trails.</description> at Maps/Norway causes trouble in launchpad as the string is cut at the first ". Not sure which way is the best to fix this.

comment:23 Changed 10 days ago by Klumbumbus

the following too:

  • <description lang="en">Historic maps - for the time being "Amtskartserien" 1826-1917.</description>
  • <description lang="en">Official administrative boundaries at the country, county, municipality and borough ("grunnkrets") levels.</description>
  • <description lang="en">Real estate boundaries from the official land register ("matrikkelen"). Monthly update.</description>
Last edited 10 days ago by Klumbumbus (previous) (diff)

comment:24 Changed 9 days ago by nkamapper

Replaced " with `and ´

comment:25 Changed 9 days ago by stoecker

Fixed parsing in [o33940].

comment:26 Changed 9 days ago by anonymous

Ticket #15655 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain nkamapper.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.