Modify

Opened 2 weeks ago

Closed 2 weeks ago

#15612 closed defect (duplicate)

Plugin ImproveWayAccuracy crash with latest JOSM

Reported by: majkaz Owned by: kolesar
Priority: normal Milestone:
Component: Plugin ImproveWay Version: latest
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  • select a way
  • select the ImproveWay plugin button

What happens?

  • crash report

Observed if "ignore error" or "disable plugin":

  • problem with all plugins later (cannot be found)
  • problem with upload of changes - needed complete JOSM restart
  • after restart and re-downloading the ImproveWay plugin, the problem remains
URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-11-28 02:52:05 +0100 (Tue, 28 Nov 2017)
Build-Date:2017-11-28 02:32:31
Revision:13174
Relative:URL: ^/trunk

Identification: JOSM/1.5 (13174 en) Windows 10 64-Bit
OS Build number: Windows 10 Enterprise 1607 (14393)
Memory Usage: 315 MB / 989 MB (141 MB allocated, but free)
Java version: 1.8.0_121-b13, Oracle Corporation, Java HotSpot(TM) Client VM
Screen: \Display0 1920x1080
Maximum Screen Size: 1920x1080
VM arguments: [-Dhttp.proxyHost=xxx, -Dhttp.proxyPort=8080, -Djosm.home=./, -Djosm.pref=./_LOC]
Dataset consistency test: No problems found

Plugins:
+ BuildingGeneralization (16)
+ CommandLine (33733)
+ EasyPresets (1511507763)
+ FastDraw (33731)
+ ImproveWay (15)
+ Mapillary (v1.5.8)
+ MovementAlert (1509877002)
+ OpeningHoursEditor (33876)
+ Tracer-testing (1505557059)
+ apache-commons (33668)
+ apache-http (32699)
+ areaselector (1505420454)
+ austriaaddresshelper (1511306130)
+ buildings_tools (33735)
+ continuosDownload (68)
+ contourmerge (1032)
+ ejml (32680)
+ ext_tools (33889)
+ geojson (73)
+ geotools (33930)
+ imagery_offset_db (33774)
+ jts (32699)
+ log4j (32699)
+ namemanager (33872)
+ opendata (33791)
+ pbf (33568)
+ pointInfo (33615)
+ pt_assistant (33860)
+ public_transport (33817)
+ public_transport_layer (33900)
+ reltoolbox (33708)
+ reverter (33865)
+ routes (33896)
+ scripting (30775)
+ tageditor (33806)
+ tagging-preset-tester (33898)
+ terracer (33839)
+ todo (30303)
+ turnlanes-tagging (260)
+ turnrestrictions (33780)
+ utilsplugin2 (33742)
+ waydownloader (33910)

Map paint styles:
+ https://www.dropbox.com/s/qo3ai47fpv241jf/Styles_Fixme_and_Notes.zip?raw=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Highway_Nodes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Modified&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/NewParkingFeatures&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/ParkingLanes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/BesideTheRoad_Speed&zip=1

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.
- E: Handled by bug report queue: java.lang.IllegalArgumentException: Listener org.openstreetmap.josm.plugins.improveway.ImproveWayAccuracyAction@c76c99 (instance of org.openstreetmap.josm.plugins.improveway.ImproveWayAccuracyAction) was already registered.


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (17) of main
java.lang.IllegalArgumentException: Listener org.openstreetmap.josm.plugins.improveway.ImproveWayAccuracyAction@c76c99 (instance of org.openstreetmap.josm.plugins.improveway.ImproveWayAccuracyAction) was already registered.
	at org.openstreetmap.josm.tools.ListenerList.failAdd(ListenerList.java:111)
	at org.openstreetmap.josm.tools.ListenerList$TracingListenerList.failAdd(ListenerList.java:202)
	at org.openstreetmap.josm.tools.ListenerList.ensureNotInList(ListenerList.java:102)
	at org.openstreetmap.josm.tools.ListenerList.addListener(ListenerList.java:94)
	at org.openstreetmap.josm.tools.ListenerList$TracingListenerList.addListener(ListenerList.java:179)
	at org.openstreetmap.josm.data.Preferences.addPreferenceChangeListener(Preferences.java:171)
	at org.openstreetmap.josm.actions.mapmode.MapMode.enterMode(MapMode.java:71)
	at org.openstreetmap.josm.plugins.improveway.ImproveWayAccuracyAction.enterMode(ImproveWayAccuracyAction.java:173)
	at org.openstreetmap.josm.gui.MapFrame.selectMapMode(MapFrame.java:477)
	at org.openstreetmap.josm.gui.MapFrame.selectMapMode(MapFrame.java:456)
	at org.openstreetmap.josm.actions.mapmode.MapMode.actionPerformed(MapMode.java:110)
	at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
	at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
	at javax.swing.JToggleButton$ToggleButtonModel.setPressed(Unknown Source)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(Unknown Source)
	at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (3)

comment:1 Changed 2 weeks ago by Don-vip

Resolution: fixed
Status: newclosed

Should be fixed in https://github.com/JOSM/improve-way/releases/tag/v1.3 can you please check?

comment:2 Changed 2 weeks ago by Don-vip

Resolution: fixed
Status: closedreopened

comment:3 Changed 2 weeks ago by Don-vip

Resolution: duplicate
Status: reopenedclosed

Closed as duplicate of #13896.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain kolesar.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.