Modify

Opened 2 weeks ago

Closed 12 days ago

#15611 closed defect (worksforme)

Error in using wms.cartografia.agenziaentrate.gov.it imagery source

Reported by: gianfranco.graizzaro@… Owned by: gianfranco.graizzaro@…
Priority: normal Milestone:
Component: External imagery source Version: tested
Keywords: imagery source wms italia Cc:

Description

What steps will reproduce the problem?

  1. Open Modify tab
  2. open Preferences
  3. open WMS TMS tab
  4. add WMS service
  5. paste link (https://wms.cartografia.agenziaentrate.gov.it/inspire/wms/ows01.php) in service URL
  6. Click obtain levels
  7. Message WMS error "Impossible to obtain WMS levels list"

Why?

What is the expected result?

I expected to obtaion level list

What happens instead?

It appairs an error message.

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-11-26 14:31:59 +0100 (Sun, 26 Nov 2017)
Build-Date:2017-11-26 13:34:54
Revision:13170
Relative:URL: ^/trunk

Identification: JOSM/1.5 (13170 it) Windows 7 64-Bit
OS Build number: Windows 7 Professional (7601)
Memory Usage: 493 MB / 910 MB (356 MB allocated, but free)
Java version: 1.8.0_151-b12, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1200, \Display1 1920x1200
Maximum Screen Size: 1920x1200

Plugins:
+ PicLayer (33822)
+ SimplifyArea (33918)
+ apache-commons (33668)
+ contourmerge (1032)
+ ejml (32680)
+ geotools (33380)
+ jts (32699)
+ opendata (33791)
+ reverter (33865)
+ turnrestrictions (33780)
+ utilsplugin2 (33742)

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.
- W: Attenzione: è fallita l'analisi del file 'site-svn.openstreetmap.org-_applications_editors_josm_plugins_opendata_modules.txt' per le informazioni del modulo. Tralascio.
- W: javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target. Causa: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target. Causa: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
- E: javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target. Causa: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target. Causa: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
- W: javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target. Causa: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target. Causa: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
- W: Already here sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
- E: javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target. Causa: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target. Causa: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
- W: javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target. Causa: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target. Causa: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
- W: Already here sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
- E: javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target. Causa: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target. Causa: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

Attachments (2)

Senza titolo-1.jpg (420.3 KB) - added by gianfranco.graizzaro@… 2 weeks ago.
screen shot
15611_worksforme.JPG (239.6 KB) - added by Don-vip 12 days ago.

Download all attachments as: .zip

Change History (6)

Changed 2 weeks ago by gianfranco.graizzaro@…

Attachment: Senza titolo-1.jpg added

screen shot

comment:1 Changed 2 weeks ago by Don-vip

Keywords: wms italia added
Owner: changed from team to gianfranco.graizzaro@…
Status: newneedinfo

The URL is probably not correct. Where did you get it from?

comment:2 Changed 2 weeks ago by Klumbumbus

It works for me, however I had to accept an certificate at first layer obtain.

Last edited 2 weeks ago by Klumbumbus (previous) (diff)

Changed 12 days ago by Don-vip

Attachment: 15611_worksforme.JPG added

comment:3 Changed 12 days ago by Don-vip

Works for me with:

Identification: JOSM/1.5 (13174 SVN en) Windows 10 64-Bit
OS Build number: Windows 10 Pro 1703 (15063)
Memory Usage: 780 MB / 3634 MB (111 MB allocated, but free)
Java version: 1.8.0_152-b16, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1080, \Display1 1920x1080, \Display2 1280x1024
Maximum Screen Size: 1920x1080
VM arguments: [-ea, -Dfile.encoding=UTF-8]


comment:4 Changed 12 days ago by Don-vip

Resolution: worksforme
Status: needinfoclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain gianfranco.graizzaro@….
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.