Modify

Opened 3 weeks ago

Closed 13 days ago

Last modified 13 days ago

#15506 closed defect (fixed)

No option to write coordinates to image header after using correlate to GPX

Reported by: bartosomail@… Owned by: bastiK
Priority: normal Milestone: 17.11
Component: Core image mapping Version: latest
Keywords: Cc: holgermappt

Description

What steps will reproduce the problem?

  1. install photo_geotagging plug-in
  2. load some images and a matching gpx track
  3. select the image layer, right click and select "Correlate to GPX"
  4. verify that the photos are matched to the GPX track
  5. Press "Correlate", verify that the images icons are moved to the expected location
  6. select the image layer, right click

What is the expected result?

In the menu, the item "Write coordinate to image header" can be selected.

What happens instead?

In the menu, the item "Write coordinate to image header" cannot be selected.

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-10-30 23:58:23 +0100 (Mon, 30 Oct 2017)
Build-Date:2017-10-31 02:33:18
Revision:13064
Relative:URL: ^/trunk

Identification: JOSM/1.5 (13064 en) Windows 7 64-Bit
OS Build number: Windows 7 Home Premium (7601)
Memory Usage: 521 MB / 989 MB (80 MB allocated, but free)
Java version: 1.8.0_151-b12, Oracle Corporation, Java HotSpot(TM) Client VM
Screen: \Display0 1600x900
Maximum Screen Size: 1600x900

Plugins:
+ ImportImagePlugin (33563)
+ Mapillary (v1.5.8)
+ OpeningHoursEditor (33185)
+ PicLayer (33385)
+ SimplifyArea (33004)
+ apache-commons (33668)
+ apache-http (32699)
+ buildings_tools (33735)
+ editgpx (33004)
+ ejml (32680)
+ geotools (33380)
+ gpxfilter (33004)
+ jts (32699)
+ log4j (32699)
+ measurement (33088)
+ merge-overlap (33436)
+ photo_geotagging (33494)
+ photoadjust (33746)
+ public_transport (33737)
+ reltoolbox (33708)
+ reverter (33572)
+ tag2link (33382)
+ terracer (33608)
+ undelete (33480)
+ utilsplugin2 (33742)
+ waydownloader (33574)
+ wikipedia (33696)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/NewParkingFeatures&preset&zip=1
+ http://osm.sebastian-klemm.eu/josm/josm-preset_parkinglane.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/Crafts&preset&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/NewTags&zip=1
+ http://somewhere.dk/email/josm/tower/tower.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/BicycleJunction&preset&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Historic_Stone&zip=1
+ http://somewhere.dk/email/josm/source.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/hiking_routes_with_trail_marking&preset&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Mountains&zip=1

Map paint styles:
+ https://josm.openstreetmap.de/josmfile?page=Styles/ParkingLanes&style&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/MaxspeedIcons&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/AddressValidator&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Sidewalks&style&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/NewParkingFeatures&style&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/DestinationSignRelation&zip=1
+ https://raw.githubusercontent.com/species/josm-preset-traffic_sign_direction/master/direction.mapcss

Last errors/warnings:
- E: Failed to locate image 'presets/parking.png'
- W:  Parking lanes: Could not get presets icon presets/parking.png
- E: Failed to locate image 'presets/parking.png'
- W:  same on both sides of street: Could not get presets icon presets/parking.png
- E: Failed to locate image 'presets/parking.png'
- W:  different on both sides of street: Could not get presets icon presets/parking.png
- W: No configuration settings found.  Using hardcoded default values for all pools.

Attachments (0)

Change History (7)

comment:1 Changed 2 weeks ago by skorbut

I can confirm this bug.

comment:2 Changed 13 days ago by bastiK

Cc: holgermappt added

Possibly caused by [13060].

holgermappt, the line curImg.flagNewGpsData(); in CorrelateGpxWithImages.java looks suspicious, why isn't it curImg.tmp.flagNewGpsData();?

comment:3 Changed 13 days ago by holgermappt

I couldn't think of side effects when I opened #15502, but this is one.

Right, it must be curImg.tmp.flagNewGpsData() at both locations. The idea is work with ImageEntry.tmp and then to ImageEntry.applyTmp() or ImageEntry.discardTmp().

It would be a good idea to add a test for ImageEntry.hasNewGpsData() to test/unit/org/openstreetmap/josm/gui/layer/geoimage/CorrelateGpxWithImagesTest.java. Something like assertTrue(i1.hasNewGpsData()) (untested).

comment:4 Changed 13 days ago by bastiK

Resolution: fixed
Status: newclosed

In 13093/josm:

fixed #15506 - No option to write coordinates to image header after using correlate to GPX

comment:5 in reply to:  3 Changed 13 days ago by bastiK

Replying to holgermappt:

It would be a good idea to add a test for ImageEntry.hasNewGpsData() to test/unit/org/openstreetmap/josm/gui/layer/geoimage/CorrelateGpxWithImagesTest.java. Something like assertTrue(i1.hasNewGpsData()) (untested).

Patch welcome! ;)

comment:6 Changed 13 days ago by bastiK

Keywords: template_report removed
Milestone: 17.11

comment:7 Changed 13 days ago by Don-vip

Component: Plugin photo_geotaggingCore image mapping

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain bastiK.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.