Modify

Opened 3 weeks ago

Closed 3 weeks ago

Last modified 3 weeks ago

#15493 closed enhancement (fixed)

Imagery Offset dialog positioning improvement

Reported by: pinkduck Owned by: team
Priority: normal Milestone: 17.10
Component: Core imagery Version: tested
Keywords: adjust, imagery, offset, dialog, position Cc:

Description

I am making detail addition edits and frequently adjust the imagery alignment to match OSM data. However, I typically do this with the area of interest in the middle of the screen, then open the alignment dialog, then have drag it out of the way each time so I can again see the middle of the screen to make the adjustment accurately.

This could be made more efficient by simply remembering the last position of the dialog. Or defaulting it to a non-central obscuring position. I usually go for somewhere near top right.

A keyboard shortcut to directly open the imagery alignment panel for the top-most active imagery layer would also be useful, given the 405 case instances I’m working through.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-10-03 21:43:00 +0200 (Tue, 03 Oct 2017)
Revision:12921
Build-Date:2017-10-03 19:50:21
URL:http://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (12921 en_GB) Windows 10 64-Bit
OS Build number: Windows 10 Pro 1703 (15063)
Memory Usage: 640 MB / 4096 MB (313 MB allocated, but free)
Java version: 9+181, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1200
Maximum Screen Size: 1920x1200
VM arguments: [-XX:HeapDumpPath=%UserProfile%\Downloads\JOSM.hprof]
Dataset consistency test: No problems found

Plugins:
+ log4j (32699)
+ pbf (33568)
+ reverter (33572)
+ terracer (33608)
+ undelete (33480)
+ utilsplugin2 (33704)

Tagging presets:
+ %UserProfile%\Documents\OpenStreetMap\JOSM Custom Presets.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/ParkingLanes&preset&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/EnglandWalesRightsOfWay&zip=1

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/ParkingLanes&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Sidewalks&style&zip=1

Attachments (0)

Change History (4)

comment:1 Changed 3 weeks ago by Don-vip

Milestone: 17.10

comment:2 Changed 3 weeks ago by Don-vip

Resolution: fixed
Status: newclosed

In 13047/josm:

fix #15493 - remember position of "Adjust Imagery Offset" dialog

comment:3 Changed 3 weeks ago by pinkduck

Thanks :)

comment:4 Changed 3 weeks ago by Don-vip

Ticket #10901 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.