Modify

Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#15449 closed defect (fixed)

JOSM version checker is broken

Reported by: Don-vip Owned by: team
Priority: normal Milestone: 17.10
Component: Core Version:
Keywords: regression Cc: stoecker

Description

Changes in r12918 makes JOSM request /tested instead of /wiki/TestedVersion?format=txt

The result of the new URL is:

<html>12921
</html>

The code does not expect to receive HTML contents and fails with NumberFormatException: Unable to detect current tested version of JOSM as seen in several recent bug reports.

Attachments (0)

Change History (6)

comment:1 Changed 3 months ago by stoecker

Why is the result surrounded by html? The website delivers

HTTP/1.1 200 OK
Date: Wed, 18 Oct 2017 08:07:42 GMT
Server: Apache/2.4.18 (Ubuntu)
X-Clacks-Overhead: GNU Terry Pratchett
Content-Length: 5
Set-Cookie: trac_session=4ee810a0f75db77ad721a4e8; expires=Tue, 16 Jan 2018 08:07:42 GMT; httponly; Path=/
Vary: Accept-Encoding
Keep-Alive: timeout=5, max=100
Connection: Keep-Alive
Content-Type: text/plain;charset=utf-8

12921

and not more. This is plain text.

comment:2 Changed 3 months ago by stoecker

Probably due to WikiReader. I searched a simple HTTP-Get class instead, but did not find one. Do you know a better method to get this single short URL?

comment:3 Changed 3 months ago by Don-vip

Yes, something like new HttpClient(url).connect().fetchContent().

comment:4 Changed 3 months ago by stoecker

Can someone else fix this? I don't have much time for this ATM and another untested change is probably not the best...

comment:5 Changed 3 months ago by bastiK

Resolution: fixed
Status: newclosed

In 13019/josm:

fixed #15449 - JOSM version checker is broken

comment:6 Changed 3 months ago by stoecker

Thanks.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.