Modify

Opened 2 months ago

Closed 2 months ago

Last modified 6 weeks ago

#15435 closed defect (fixed)

do not cache incorrect login credentials

Reported by: jose1711 Owned by: team
Priority: normal Milestone: 17.10
Component: Core Version: latest
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. run josm, download any area and make a *valid* edit
  2. make sure you do not have OSM credentials stored (OSM username and password is empty)
  3. hit upload
  4. enter your username and INCORRECT password
  5. get an error message
  6. now try to recover from this situation - upload again

What is the expected result?

josm should ask user/password combination on successive upload attempt

What happens instead?

it does not ask anything and just keeps showing the error message. the only remediation i found is to restart JOSM.

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-10-03 21:43:00 +0200 (Tue, 03 Oct 2017)
Build-Date:2017-10-03 19:50:21
Revision:12921
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12921 sk) Linux Arch Linux
Memory Usage: 336 MB / 1328 MB (108 MB allocated, but free)
Java version: 1.8.0_144-b01, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 3744x1024, :0.1 1024x768, :0.2 1440x900
Maximum Screen Size: 3744x1024
VM arguments: [-Djosm.restart=true]

Plugins:
+ CommandLine (33368)
+ PicLayer (33385)
+ SimplifyArea (33004)
+ buildings_tools (33004)
+ freemapkapor (53)
+ reverter (33572)
+ undelete (33480)
+ utilsplugin2 (33704)

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.

Attachments (0)

Change History (3)

comment:1 Changed 2 months ago by Don-vip

Milestone: 17.10

comment:2 Changed 2 months ago by Don-vip

Resolution: fixed
Status: newclosed

In 12992/josm:

fix #15435 - do not cache incorrect login credentials when using basic auth

comment:3 Changed 6 weeks ago by Don-vip

Ticket #15496 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.