Modify

Opened 2 months ago

Closed 2 months ago

Last modified 7 weeks ago

#15429 closed defect (fixed)

NoSuchElementException at AlignInLineAction.alignMultiWay

Reported by: anonymous Owned by: Don-vip
Priority: normal Milestone: 17.10
Component: Core Version:
Keywords: template_report Cc:

Description (last modified by Don-vip)

What steps will reproduce the problem?

  1. when pressing F3 key

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-10-03 21:43:00 +0200 (Tue, 03 Oct 2017)
Build-Date:2017-10-03 19:50:21
Revision:12921
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12921 fr) Windows 7 64-Bit
OS Build number: Windows 7 Professional (7601)
Memory Usage: 1044 MB / 1806 MB (639 MB allocated, but free)
Java version: 1.8.0_144-b01, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1440x900, \Display1 1440x900
Maximum Screen Size: 1440x900
Dataset consistency test: No problems found

Plugins:
+ DirectDownload (33160)
+ HouseNumberTaggingTool (33160)
+ ImportImagePlugin (33563)
+ Mapillary (v1.5.7)
+ OpeningHoursEditor (33185)
+ PicLayer (33385)
+ SeaChart (33222)
+ SeaMapEditor (33054)
+ apache-commons (33668)
+ apache-http (32699)
+ buildings_tools (33004)
+ cadastre-fr (33690)
+ download_along (32946)
+ ejml (32680)
+ fieldpapers (v0.4.2)
+ geotools (33380)
+ importvec (33564)
+ jts (32699)
+ log4j (32699)
+ measurement (33088)
+ osmarender (33004)
+ pdfimport (33579)
+ reverter (33572)
+ tageditor (33579)
+ utilsplugin2 (33677)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/Diving&zip=1
+ %UserProfile%\Google Drive\SIG\JOSM, pré-réglages\plongée.xml
+ %UserProfile%\Downloads\JOSM Presets\Presets_Camp_site_extends-preset.xml
+ %UserProfile%\Downloads\JOSM Presets\Presets_CampingForOverlanders-preset.xml
+ %UserProfile%\Downloads\JOSM Presets\Presets_LaneAttributes-preset.xml
+ %UserProfile%\Downloads\JOSM Presets\Presets_OpenSeaMap-PresetForSeamarks-preset.xml
+ %UserProfile%\Downloads\JOSM Presets\Presets_Diving-preset.xml

Last errors/warnings:
- E: %UserProfile%\Downloads\JOSM Presets\Presets_CampingForOverlanders-preset.xml
- E: java.io.FileNotFoundException: %UserProfile%\Downloads\JOSM Presets\Presets_LaneAttributes-preset.xml (Le chemin d’accès spécifié est introuvable)
- E: %UserProfile%\Downloads\JOSM Presets\Presets_LaneAttributes-preset.xml
- E: java.io.FileNotFoundException: %UserProfile%\Downloads\JOSM Presets\Presets_OpenSeaMap-PresetForSeamarks-preset.xml (Le chemin d’accès spécifié est introuvable)
- E: %UserProfile%\Downloads\JOSM Presets\Presets_OpenSeaMap-PresetForSeamarks-preset.xml
- E: java.io.FileNotFoundException: %UserProfile%\Downloads\JOSM Presets\Presets_Diving-preset.xml (Le chemin d’accès spécifié est introuvable)
- E: %UserProfile%\Downloads\JOSM Presets\Presets_Diving-preset.xml
- W: No configuration settings found.  Using hardcoded default values for all pools.
- E: Handled by bug report queue: java.util.NoSuchElementException
- W: Unable to detect current tested version of JOSM:: java.lang.NumberFormatException: For input string: "<html>12921


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (19) of main
java.util.NoSuchElementException
	at java.util.ArrayList$Itr.next(Unknown Source)
	at org.openstreetmap.josm.command.SequenceCommand.<init>(SequenceCommand.java:57)
	at org.openstreetmap.josm.command.SequenceCommand.<init>(SequenceCommand.java:66)
	at org.openstreetmap.josm.actions.AlignInLineAction.alignMultiWay(AlignInLineAction.java:275)
	at org.openstreetmap.josm.actions.AlignInLineAction.buildCommand(AlignInLineAction.java:198)
	at org.openstreetmap.josm.actions.AlignInLineAction.actionPerformed(AlignInLineAction.java:174)
	at javax.swing.SwingUtilities.notifyAction(Unknown Source)
	at javax.swing.JComponent.processKeyBinding(Unknown Source)
	at javax.swing.KeyboardManager.fireBinding(Unknown Source)
	at javax.swing.KeyboardManager.fireKeyboardAction(Unknown Source)
	at javax.swing.JComponent.processKeyBindingsForAllComponents(Unknown Source)
	at javax.swing.JComponent.processKeyBindings(Unknown Source)
	at javax.swing.JComponent.processKeyEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.KeyboardFocusManager.redispatchEvent(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.dispatchEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (3)

comment:1 Changed 2 months ago by Don-vip

Description: modified (diff)
Milestone: 17.10
Owner: changed from team to Don-vip
Status: newassigned
Summary: when pressing F3 keyNoSuchElementException at AlignInLineAction.alignMultiWay

comment:2 Changed 2 months ago by Don-vip

Resolution: fixed
Status: assignedclosed

In 12984/josm:

fix #15429 - add robustness to AlignInLineAction

comment:3 Changed 7 weeks ago by Don-vip

Ticket #15491 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.