Modify

Opened 3 weeks ago

Closed 3 weeks ago

Last modified 3 weeks ago

#15395 closed defect (fixed)

Failed to create missing cache directory

Reported by: anonymous Owned by: team
Priority: blocker Milestone: 17.09
Component: Core Version:
Keywords: regression Cc:

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-10-01 19:25:11 +0200 (Sun, 01 Oct 2017)
Build-Date:2017-10-02 01:34:05
Revision:12914
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12914 en) Mac OS X
Memory Usage: 353 MB / 910 MB (238 MB allocated, but free)
Java version: 1.8.0_144-b01, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: Display 69677890 1920x1200
Maximum Screen Size: 1920x1200
VM arguments: [-Djava.library.path=/private/var/folders/2y/6pjc6wpx4nl3ynggm43g52fc0000gn/T/AppTranslocation/D4289EAE-FAD3-4F0E-A008-CECBF7A89880/d/JOSM.app/Contents/MacOS, -DLibraryDirectory=${HOME}/Library, -DDocumentsDirectory=${HOME}/Documents, -DApplicationSupportDirectory=${HOME}/Library/Application Support, -DCachesDirectory=${HOME}/Library/Caches, -DSandboxEnabled=false, -Dapple.laf.useScreenMenuBar=true, -Dcom.apple.macos.use-file-dialog-packages=true, -Dcom.apple.macos.useScreenMenuBar=true, -Dcom.apple.mrj.application.apple.menu.about.name=JOSM, -Dcom.apple.smallTabs=true]

Last errors/warnings:
- W: Failed to create missing cache directory: <josm.cache>
- W: Failed to create missing cache directory: <josm.cache>
- W: Failed to create missing cache directory: <josm.cache>
- W: Failed to create missing cache directory: <josm.cache>
- W: Unable to create directory <josm.cache>
- E: java.nio.file.NoSuchFileException: <josm.cache>/mirror_https___josm.openstreetmap.de_maps.tmp
- E: java.io.FileNotFoundException: <josm.cache>/capabilities1637351842 (No such file or directory)
- E: java.io.FileNotFoundException: <josm.cache>/motd.html (No such file or directory)
- W: Failed to create missing cache directory: <josm.cache>
- E: Handled by bug report queue: org.openstreetmap.josm.tools.JosmRuntimeException: java.util.concurrent.ExecutionException: org.openstreetmap.josm.tools.JosmRuntimeException: java.io.FileNotFoundException: <josm.cache>/left-right-hand-traffic.osm (No such file or directory). Cause: java.util.concurrent.ExecutionException: org.openstreetmap.josm.tools.JosmRuntimeException: java.io.FileNotFoundException: <josm.cache>/left-right-hand-traffic.osm (No such file or directory). Cause: org.openstreetmap.josm.tools.JosmRuntimeException: java.io.FileNotFoundException: <josm.cache>/left-right-hand-traffic.osm (No such file or directory). Cause: java.io.FileNotFoundException: <josm.cache>/left-right-hand-traffic.osm (No such file or directory)


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: main (1)
org.openstreetmap.josm.tools.JosmRuntimeException: java.util.concurrent.ExecutionException: org.openstreetmap.josm.tools.JosmRuntimeException: java.io.FileNotFoundException: /Users/administrator/.cache/JOSM/left-right-hand-traffic.osm (No such file or directory)
	at org.openstreetmap.josm.Main.initialize(Main.java:519)
	at org.openstreetmap.josm.gui.MainApplication.mainJOSM(MainApplication.java:1023)
	at org.openstreetmap.josm.gui.MainApplication$2.processArguments(MainApplication.java:276)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:860)
Caused by: java.util.concurrent.ExecutionException: org.openstreetmap.josm.tools.JosmRuntimeException: java.io.FileNotFoundException: /Users/administrator/.cache/JOSM/left-right-hand-traffic.osm (No such file or directory)
	at java.util.concurrent.FutureTask.report(FutureTask.java:122)
	at java.util.concurrent.FutureTask.get(FutureTask.java:192)
	at org.openstreetmap.josm.Main.initialize(Main.java:512)
	... 3 more
Caused by: org.openstreetmap.josm.tools.JosmRuntimeException: java.io.FileNotFoundException: /Users/administrator/.cache/JOSM/left-right-hand-traffic.osm (No such file or directory)
	at org.openstreetmap.josm.tools.RightAndLefthandTraffic.saveOptimizedBoundaries(RightAndLefthandTraffic.java:163)
	at org.openstreetmap.josm.tools.RightAndLefthandTraffic.initialize(RightAndLefthandTraffic.java:68)
	at org.openstreetmap.josm.Main$InitializationTask.call(Main.java:603)
	at org.openstreetmap.josm.Main$InitializationTask.call(Main.java:582)
	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
	at java.lang.Thread.run(Thread.java:748)
Caused by: java.io.FileNotFoundException: /Users/administrator/.cache/JOSM/left-right-hand-traffic.osm (No such file or directory)
	at java.io.FileOutputStream.open0(Native Method)
	at java.io.FileOutputStream.open(FileOutputStream.java:270)
	at java.io.FileOutputStream.<init>(FileOutputStream.java:213)
	at java.io.FileOutputStream.<init>(FileOutputStream.java:162)
	at org.openstreetmap.josm.tools.RightAndLefthandTraffic.saveOptimizedBoundaries(RightAndLefthandTraffic.java:156)
	... 7 more

Attachments (0)

Change History (5)

comment:1 Changed 3 weeks ago by bastiK

Resolution: fixed
Status: newclosed

In 12919/josm:

fixed #15395 - typo in assigning platform hook

comment:2 Changed 3 weeks ago by bastiK

Keywords: regression added; template_report removed
Milestone: 17.09
Priority: normalblocker

comment:3 Changed 3 weeks ago by Don-vip

ouh! clearly we lack of users testing JOSM latest on macOS!

comment:4 Changed 3 weeks ago by bastiK

On the plus side, we now have a palindrome version number.

comment:5 Changed 3 weeks ago by Don-vip

oh, nice :)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.