Modify

Opened 2 months ago

Closed 2 months ago

Last modified 2 months ago

#15375 closed defect (fixed)

JOSM freezes after showing popup for unsuccesfull search

Reported by: GerdP Owned by: team
Priority: normal Milestone: 17.09
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

See also #15198
1) Start JOSM
2) Open Bing as background layer
3) Load some data (In aktueller Ansicht herunterladen)
4) Search for something that doesn't exist,e.g. blabla -> JOSM shows popup "Nichts gefunden für blabla"
5) Use Alt+Tab to switch to a different Windows application and type something in this application
6) Use Alt+Tag to switch back to JOSM
7) Press Esc to close the popup

What is the expected result?

popup should disappear

What happens instead?

JOSM freezes and shows no reaction on any mouse or keyboard action

Please provide any additional information below. Attach a screenshot if possible.

Build-Date:2017-09-30 15:54:03
Revision:12910
Is-Local-Build:true

Identification: JOSM/1.5 (12910 SVN de) Windows 10 64-Bit
OS Build number: Windows 10 Home 1703 (15063)
Memory Usage: 1636 MB / 5461 MB (1498 MB allocated, but free)
Java version: 1.8.0_144-b01, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1080
Maximum Screen Size: 1920x1080

Plugins:
+ OpeningHoursEditor (33185)
+ apache-commons (33668)
+ buildings_tools (33004)
+ ejml (32680)
+ geotools (33380)
+ jts (32699)
+ o5m (33566)
+ opendata (33617)
+ pbf (33568)
+ poly (33570)
+ reverter (33572)
+ utilsplugin2 (33677)

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.
- W: Cannot start IPv4 remotecontrol https server on port 8112: Keystore was tampered with, or password was incorrect
- W: Cannot start IPv6 remotecontrol https server on port 8112: Keystore was tampered with, or password was incorrect

Attachments (1)

threaddump-12910.txt (51.4 KB) - added by GerdP 2 months ago.

Download all attachments as: .zip

Change History (10)

Changed 2 months ago by GerdP

Attachment: threaddump-12910.txt added

comment:1 Changed 2 months ago by GerdP

Just tried without Bing, same problem. It seems I can reproduce this problem each time I try.

comment:2 Changed 2 months ago by bastiK

Please also try with the binary downloaded from the JOSM server. There can be subtle differences with a local build.

comment:3 Changed 2 months ago by GerdP

Can reproduce it with r12908 from JOSM server as well.

comment:4 Changed 2 months ago by Don-vip

I still can't reproduce it...

comment:5 Changed 2 months ago by Don-vip

Milestone: 17.09

comment:6 Changed 2 months ago by Don-vip

Resolution: fixed
Status: newclosed

In 12912/josm:

fix #15375 - display a non blocking notification in case of unsuccessful search

comment:7 Changed 2 months ago by bastiK

GerdP, could you open the imagery preferences and click the 'activate' button (it says "Please select at least one row to copy."). Do you get the same issue when tabbing out?

comment:8 Changed 2 months ago by GerdP

No, tried a few times with downloaded r12908, no problems. But I am now also unable to reproduce the original problem.
I now have the suspicion that this could be related to my antivirus (Avira). Maybe the problem only occurs shortly after starting / awaking Windows. In this phase Avira starts its update process and this sometimes changes the mouse cursor, so maybe it is somehow stealing the focus. Does that make sense?
I'll try again both cases tomorrow.

comment:9 Changed 2 months ago by GerdP

Well, I am clueless. I tried several times and I am no longer able to reproduce the original problem. I assume it is/was something special in my installation.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.