Modify

Opened 2 months ago

Closed 2 months ago

Last modified 2 months ago

#15305 closed defect (invalid)

.osm.pbf file does not open

Reported by: johnparis Owned by: Don-vip
Priority: normal Milestone:
Component: Plugin pbf Version:
Keywords: template_report Cc:

Description (last modified by Don-vip)

What steps will reproduce the problem?

  1. File->Open
  2. search for .osm.pbf file using "All Formats"
  3. OR manually type in name of file

What is the expected result?

File loads

What happens instead?

Error "No importer" (see screenshot)

Please provide any additional information below. Attach a screenshot if possible.

PBF plugin is loaded and activated (see screenshot). However, a properly named .osm.pbf file is in my Downloads directory and does not appear under "File->Open". When I type in the name manually, I get the "no importer" message (see screenshot).

Screenshot of error message

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-09-02 14:47:18 +0200 (Sat, 02 Sep 2017)
Build-Date:2017-09-02 20:53:16
Revision:12712
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12712 en) Linux Fedora release 26 (Twenty Six)
Memory Usage: 621 MB / 1758 MB (180 MB allocated, but free)
Java version: 1.8.0_144-b01, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1600x900
Maximum Screen Size: 1600x900
Java package: openjdk-8-jre:package openjdk-8-jre is not installed
VM arguments: [-agentpath:/usr/lib/abrt-java-connector/libabrt-java-connector.so=abrt=on]

Plugins:
+ PicLayer (33385)
+ apache-commons (33517)
+ ejml (32680)
+ geotools (33380)
+ jts (32699)
+ log4j (32699)
+ measurement (33088)
+ pbf (33568)
+ pdfimport (33579)
+ pt_assistant (33571)
+ reverter (33572)
+ scripting (30771)
+ utilsplugin2 (33579)

Attachments (2)

Screenshot from 2017-09-14 10-35-26.png (374.4 KB) - added by johnparis 2 months ago.
Plugin activated
Screenshot from 2017-09-14 10-34-55.png (11.9 KB) - added by johnparis 2 months ago.
Screenshot of error message

Download all attachments as: .zip

Change History (5)

Changed 2 months ago by johnparis

Plugin activated

Changed 2 months ago by johnparis

Screenshot of error message

comment:1 Changed 2 months ago by floscher

Could it be, that the file is not recognized because it's named morocco.osh.pbf ? Just a guess…

comment:2 in reply to:  1 Changed 2 months ago by Don-vip

Resolution: invalid
Status: newclosed

Replying to floscher:

Could it be, that the file is not recognized because it's named morocco.osh.pbf ? Just a guess…

:D

comment:3 Changed 2 months ago by Don-vip

Description: modified (diff)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.