Modify

Opened 2 months ago

Closed 8 weeks ago

#15291 closed defect (duplicate)

IAE: Comparison method violates its general contract!

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. downloaded http://localhost:8111/import?new_layer=true&url=https://cliffordsnow.github.io/Florida/osm/121030173.osm.gz
  2. Ctrl A , Ctrl C and ctrl alt V into a new layer
  3. Uploaded the imported

What is the expected result?

What happens instead?

upload still works but ram usage goes exceptional high and this error was thrown 5 times and could only be discarded after the upload finished

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-09-07 01:05:36 +0200 (Thu, 07 Sep 2017)
Build-Date:2017-09-07 01:31:05
Revision:12767
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12767 de) Windows Vista 32-Bit
OS Build number: Windows Vista (TM) Business (6002)
Memory Usage: 989 MB / 989 MB (451 MB allocated, but free)
Java version: 1.8.0_141-b15, Oracle Corporation, Java HotSpot(TM) Client VM
Screen: \Display0 1680x1050
Maximum Screen Size: 1680x1050
Dataset consistency test: No problems found

Plugins:
+ OpeningHoursEditor (33185)
+ RoadSigns (33579)
+ buildings_tools (33004)
+ continuosDownload (53)
+ contourmerge (1030)
+ download_along (32946)
+ log4j (32699)
+ reverter (33572)
+ rex (26)
+ tageditor (33579)
+ terracer (33579)
+ turnlanes-tagging (254)
+ turnrestrictions (33537)
+ undelete (33480)
+ utilsplugin2 (33579)

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/LessObtrusiveNodes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/PublicTransport&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lit&zip=1

Last errors/warnings:
- E: Handled by bug report queue: java.lang.IllegalArgumentException: Comparison method violates its general contract!
- E: Handled by bug report queue: java.lang.IllegalArgumentException: Comparison method violates its general contract!
- E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive must be part of the dataset: {Node id=5096981036 version=1 MV lat=27.845347057999994,lon=-82.804359536}
- E: Handled by bug report queue: java.lang.IllegalArgumentException: Comparison method violates its general contract!
- E: Handled by bug report queue: java.lang.IllegalArgumentException: Comparison method violates its general contract!
- E: Handled by bug report queue: java.lang.IllegalArgumentException: Comparison method violates its general contract!
- E: Handled by bug report queue: java.lang.IllegalArgumentException: Comparison method violates its general contract!
- E: Handled by bug report queue: java.lang.IllegalArgumentException: Comparison method violates its general contract!
- E: Handled by bug report queue: java.lang.IllegalArgumentException: Comparison method violates its general contract!
- E: Handled by bug report queue: java.lang.IllegalArgumentException: Comparison method violates its general contract!


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (17) of main
java.lang.IllegalArgumentException: Comparison method violates its general contract!
	at java.util.TimSort.mergeLo(Unknown Source)
	at java.util.TimSort.mergeAt(Unknown Source)
	at java.util.TimSort.mergeForceCollapse(Unknown Source)
	at java.util.TimSort.sort(Unknown Source)
	at java.util.Arrays.sort(Unknown Source)
	at java.util.ArrayList.sort(Unknown Source)
	at org.openstreetmap.josm.gui.dialogs.SelectionListDialog$SelectionListModel.sort(SelectionListDialog.java:669)
	at org.openstreetmap.josm.gui.dialogs.SelectionListDialog$SelectionListModel.setJOSMSelection(SelectionListDialog.java:611)
	at org.openstreetmap.josm.gui.dialogs.SelectionListDialog$SelectionListModel.selectionChanged(SelectionListDialog.java:695)
	at org.openstreetmap.josm.data.osm.event.SelectionEventManager$OldListenerInfo.fire(SelectionEventManager.java:57)
	at org.openstreetmap.josm.data.osm.event.SelectionEventManager.fireEvent(SelectionEventManager.java:203)
	at org.openstreetmap.josm.data.osm.event.SelectionEventManager.lambda$selectionChanged$0(SelectionEventManager.java:198)
	at java.awt.event.InvocationEvent.dispatch(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.WaitDispatchSupport$2.run(Unknown Source)
	at java.awt.WaitDispatchSupport$4.run(Unknown Source)
	at java.awt.WaitDispatchSupport$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.WaitDispatchSupport.enter(Unknown Source)
	at java.awt.Dialog.show(Unknown Source)
	at java.awt.Component.show(Unknown Source)
	at java.awt.Component.setVisible(Unknown Source)
	at java.awt.Window.setVisible(Unknown Source)
	at java.awt.Dialog.setVisible(Unknown Source)
	at org.openstreetmap.josm.gui.progress.swing.PleaseWaitProgressMonitor.lambda$doBeginTask$3(PleaseWaitProgressMonitor.java:256)
	at org.openstreetmap.josm.gui.progress.swing.PleaseWaitProgressMonitor.lambda$doInEDT$0(PleaseWaitProgressMonitor.java:114)
	at java.awt.event.InvocationEvent.dispatch(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (3)

comment:1 Changed 2 months ago by anonymous

What steps will reproduce the problem?

  1. downloaded ​http://localhost:8111/import?new_layer=true&url=https://cliffordsnow.github.io/Florida/osm/121030173.osm.gz
  2. Ctrl A , Ctrl C and ctrl alt V into a new layer
  3. Uploaded the layer while still all nodes were selected

comment:2 Changed 2 months ago by Don-vip

Summary: error while uploadingIAE: Comparison method violates its general contract!

comment:3 Changed 8 weeks ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #15361.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.