Modify

Opened 2 months ago

Closed 13 days ago

Last modified 12 days ago

#15269 closed enhancement (fixed)

Complain about bare tourism=attraction

Reported by: mkoniecz Owned by: team
Priority: normal Milestone: 17.11
Component: Core validator Version:
Keywords: template_report tourism Cc:

Description (last modified by Klumbumbus)

What steps will reproduce the problem?

  1. Create osmwiki:Tag:tourism=attraction node
  2. select it
  3. run validator
  4. add name tag to the node
  5. select it
  6. run validator

What is the expected result?

In steps 3 and 6 validator will complain about lack of any tags beyond tourism=attraction and name tags.

What happens instead?

Nothing reported.

Please provide any additional information below. Attach a screenshot if possible.

Such objects are frequently added by MAPS.ME.

http://overpass-turbo.eu/s/ryl detects such mistakes

http://www.openstreetmap.org/node/5043840886 is an example of a problematic object

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-09-04 00:29:05 +0200 (Mon, 04 Sep 2017)
Build-Date:2017-09-03 22:31:22
Revision:12717
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12717 en) Linux Ubuntu 16.04.3 LTS
Memory Usage: 292 MB / 871 MB (61 MB allocated, but free)
Java version: 1.8.0_144-b01, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: :0.0 1920x1080
Maximum Screen Size: 1920x1080

Plugins:
+ OpeningHoursEditor (33185)
+ buildings_tools (33004)
+ lakewalker (33161)

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/AdvertisingStyle&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/MaxspeedIcons&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/LessObtrusiveNodes&zip=1
+ ${HOME}/Documents/install_moje/josm_style_sidewalks/Styles_Sidewalks-style.mapcss

Validator rules:
+ ${HOME}/Documents/install_moje/josm_validator/josm.validator.mapcss

Last errors/warnings:
- W: java.net.SocketTimeoutException: Read timed out
- E: java.net.SocketTimeoutException: Read timed out
- W: org.openstreetmap.josm.tools.bugreport.BugReportSender$BugReportSenderException: java.net.SocketTimeoutException: Read timed out. Cause: java.net.SocketTimeoutException: Read timed out

Attachments (0)

Change History (15)

comment:1 Changed 2 months ago by mkoniecz

Summary: Complain about bare tourims=attractionComplain about bare tourism=attraction

comment:2 Changed 2 months ago by mkoniecz

Description: modified (diff)

comment:4 Changed 2 months ago by Klumbumbus

Description: modified (diff)

comment:5 Changed 2 months ago by Klumbumbus

I don't understand whats wrong with tourism=attraction + name=*

There is no other mandatory "subkey". See also https://taginfo.openstreetmap.org/tags/?key=tourism&value=attraction#combinations

comment:6 Changed 2 months ago by mkoniecz

The problem is that it is never complete and frequently indicates duplicated object. There is always something that is tourism attraction - tree, castle, stream, cave, statue, locomotive etc.

And very often maps.me and iD users add tourism=attraction that duplicate existing objects.

It is quite similar to #9593, though here I suggest to not maintain some list of keys but accept any tag (as many different things may become a tourism attraction).

For example https://www.openstreetmap.org/changeset/51839851 fixed tourism=attraction tagged as a separate node rather than on a PoW, before https://www.openstreetmap.org/changeset/51839756 spring and tourism=attraction was on separate nodes, before https://www.openstreetmap.org/changeset/51839579 tourism=attraction and building was tagged as separate objects, before https://www.openstreetmap.org/changeset/51839546 tourism=attraction was used instead of specifying what is the tourism attraction, before https://www.openstreetmap.org/changeset/51839218 it was not tagged what is a tourism attraction etc

comment:7 Changed 2 months ago by mkoniecz

See also "This tag is often used in addition with other tags (like historic=*) to express that the place is interesting for tourists." at https://wiki.openstreetmap.org/wiki/Tag%3Atourism%3Dattraction

comment:8 Changed 2 months ago by mkoniecz

I added at wiki "For example tourism=attraction + name=Waterfall "Foobar" is not enough, such object should be tagged rather with waterway=waterfall + tourism=attraction + name=Foobar." to better describe the problem.

comment:9 Changed 8 weeks ago by Don-vip

I found values where it could be difficult to add something else. Example, spots in big zoos/natural parks (lions, monkeys, etc.), places in big museums, attraction parks. But I also found some occurrences where the check would be useful. So maybe at info level, not warning.

comment:10 Changed 8 weeks ago by Don-vip

Keywords: tourism added

comment:11 Changed 8 weeks ago by mkoniecz

spots in big zoos/natural parks (lions, monkeys, etc.)

http://wiki.openstreetmap.org/wiki/Tag:tourism%3Dzoo#Animal has proposed tagging (" tourism=attraction, attraction=animal, name=African Elephant")

comment:12 Changed 8 weeks ago by Don-vip

Ah I didn't see the attraction key, there are also values for attraction parks & co. I change my mind: +1 for a warning.

comment:13 Changed 3 weeks ago by Klumbumbus

Milestone: 17.11

comment:14 Changed 13 days ago by Klumbumbus

Resolution: fixed
Status: newclosed

In 13086/josm:

fix #15269 - Warn about bare tourism=attraction

comment:15 Changed 12 days ago by mkoniecz

Thanks!

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.