Modify

Opened 6 weeks ago

Closed 9 days ago

#15267 closed defect (fixed)

Small problems with "Download from Overpass API" dialog

Reported by: GerdP Owned by: GerdP
Priority: normal Milestone: 17.09
Component: Core Version:
Keywords: template_report overpass download Cc:

Description (last modified by Don-vip)

What steps will reproduce the problem?

  1. Press Ctrl+Shift+Down for download dialog
  2. chose tab "Download from Overpass API"
  3. click button "Query Wizard" and generate query for e.g. "type:way and highway=driveway global"
  4. close download dialog
  5. close JOSM
  6. start JOSM
  7. repeat 1+2

What is the expected result?

Window "Overpass query" should contain the last generated query

What happens instead?

The window contains comment "Place your Overpass query below or generate one using the Overpass Turbo Query Wizard"

Please provide any additional information below. Attach a screenshot if possible.

Other problems:
When I press the query wizard button again (as step 8) it shows an empty field "Search:"
Whenn I click on the button on the left side my last used query is shown at the end of the list (order seems reversed).
It seems not possible to select the first entry in the list using the mouse when the search field is empty. If the search field already contains a text I can select the first entry

Build-Date:2017-09-08 07:30:37
Revision:12783
Is-Local-Build:true

Identification: JOSM/1.5 (12783 SVN en) Windows 10 64-Bit
OS Build number: Windows 10 Home 1703 (15063)
Memory Usage: 1628 MB / 5461 MB (1433 MB allocated, but free)
Java version: 1.8.0_121-b13, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1080
Maximum Screen Size: 1920x1080

Plugins:
+ OpeningHoursEditor (33185)
+ apache-commons (33517)
+ buildings_tools (33004)
+ ejml (32680)
+ geotools (33380)
+ jts (32699)
+ o5m (33566)
+ opendata (33553)
+ pbf (33568)
+ poly (33570)
+ reverter (33572)
+ utilsplugin2 (33579)

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.
- W: Cannot start IPv4 remotecontrol https server on port 8112: Keystore was tampered with, or password was incorrect
- W: Cannot start IPv6 remotecontrol https server on port 8112: Keystore was tampered with, or password was incorrect

Attachments (1)

wizard-history.patch (627 bytes) - added by GerdP 11 days ago.

Download all attachments as: .zip

Change History (21)

comment:1 Changed 4 weeks ago by Don-vip

Description: modified (diff)

comment:2 Changed 4 weeks ago by Don-vip

Keywords: overpass download added
Milestone: 17.09

comment:3 Changed 4 weeks ago by Don-vip

Resolution: fixed
Status: newclosed

In 12903/josm:

fix #15267 - fix various usability problems with new download dialog

comment:4 Changed 4 weeks ago by Don-vip

In 12904/josm:

see #15267 - fix error in previous commit

comment:5 Changed 3 weeks ago by GerdP

Much better now. One problem remains which I did not mention before: The window / box for the overpass query is sometimes much too small
after starting JOSM. In some cases it was only visible after using the mouse to enlarge it.

comment:6 Changed 3 weeks ago by GerdP

Oops, one new problem: The generated queries are no longer stored.

comment:7 Changed 3 weeks ago by GerdP

It seems the query wizzard dialog now shows an old query but not the last one that I used.

comment:8 Changed 3 weeks ago by Don-vip

Resolution: fixed
Status: closedreopened

comment:9 in reply to:  6 Changed 3 weeks ago by Don-vip

Owner: changed from team to GerdP
Status: reopenedneedinfo

Replying to GerdP:

Oops, one new problem: The generated queries are no longer stored.

Can you please elaborate/post a detailed scenario to reproduce the problem? I don't see anything suspicious.

comment:10 Changed 3 weeks ago by GerdP

I can't with r12904.
Maybe this happened only with the queries that were produced with the older version when switching to the newer.

comment:11 Changed 3 weeks ago by Don-vip

Resolution: fixed
Status: needinfoclosed

comment:12 Changed 3 weeks ago by GerdP

Ah, sorry, maybe I misunderstood you. I can still repproduce the problems in comment 7.
The query shown in the wizzard is not the last one that I entered. Maybe this is related to my workflow.
From time to time I use the wizzard to generate a query, next I may simply edit the generated query a few times before
using the wizzard again.

I've now updated JDK and JRE to build 1.8.0_144-b01 and JOSM to 12910 (from svn).
I've compiled with ant dist clean and started JOSM.
I updated the plugins.
After this all the stored queries are gone again. The query wizzard lines are still there.
I select one and generate the query and when I stop and start JOSM this generated query is again listed.
So I think we have two problems here.
1) Order in the query wizzard history line
2) Loss of all stored queries after updating JOSM to a newer release.

Last edited 3 weeks ago by GerdP (previous) (diff)

comment:13 Changed 11 days ago by GerdP

Resolution: fixed
Status: closedreopened

I'll try to find out what is wrong.

Changed 11 days ago by GerdP

Attachment: wizard-history.patch added

comment:14 Changed 11 days ago by GerdP

Please review the patch. With it the query wizard shows the last used (newest) query as default. The source is quite confusing,
list is reversed for the dialog which then shows the newest entry at top while the list contains it at the end.

comment:15 Changed 11 days ago by Don-vip

I think I don't understand your problem. Remove the reverse() call I've added to fix this ticket instead.

comment:16 Changed 11 days ago by GerdP

That was my thought as well, but then the newest entry in the drop down list is at the bottom.

Last edited 11 days ago by GerdP (previous) (diff)

comment:17 Changed 11 days ago by GerdP

In 12977/josm:

see #15267 Let Overpass Query Wizard show newest entry instead of oldest

comment:18 Changed 11 days ago by GerdP

Remains the problem that JOSM doesn't store the overpass queries that are kept in OverpassDownloadSourcePanel.overpassQueryList,
only the last used query is stored in property download.overpass.query.
Maybe we can use a ListHistory for the last x queries as well?

comment:19 Changed 9 days ago by GerdP

Well, I gave up because this requires a bit more work. The list box shows a timestamp, not the executed query. The timestamp has not much meaning itself, it just helps to sort the elements. If we want store the queries in preferences.xml we need some logic to separate the query context and the timestamp value. Probably more interesting would be a method to store the query together with a small description, maybe not in preferences.xml but as a file. Or maybe as a permanent link like it is possible in the overpass dialog?
I leave that to the dialog experts.

comment:20 Changed 9 days ago by Don-vip

Resolution: fixed
Status: reopenedclosed

Ok. Please open a new ticket then, this one has been closed in last milestone.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain GerdP.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.