Modify

Opened 3 weeks ago

Closed 3 weeks ago

#15254 closed defect (fixed)

NoSuchElementException with turnlanes-tagging

Reported by: naoliv Owned by: Don-vip
Priority: normal Milestone: 17.09
Component: Core Version:
Keywords: regression Cc:

Description

After using the turnlanes-tagging plugin to add turn:lanes into a way, I got this:

2017-09-06 15:04:39.383 GRAVE: Handled by bug report queue: java.util.NoSuchElementException
java.util.NoSuchElementException
	at java.util.ArrayList$Itr.next(ArrayList.java:854)
	at org.openstreetmap.josm.command.SequenceCommand.<init>(SequenceCommand.java:57)
	at org.openstreetmap.josm.command.SequenceCommand.<init>(SequenceCommand.java:66)
	at org.openstreetmap.josm.gui.tagging.TagEditorModel.createDeleteTagsCommand(TagEditorModel.java:548)
	at org.openstreetmap.josm.plugins.tageditor.editor.TagEditorModel.updateJOSMSelection(TagEditorModel.java:158)
	at org.openstreetmap.josm.plugins.turnlanestagging.TurnLanesEditorDialog$OKAction.run(TurnLanesEditorDialog.java:201)
	at org.openstreetmap.josm.plugins.turnlanestagging.TurnLanesEditorDialog$OKAction.actionPerformed(TurnLanesEditorDialog.java:191)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2022)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2348)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:402)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:252)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:289)
	at java.awt.Component.processMouseEvent(Component.java:6533)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3324)
	at java.awt.Component.processEvent(Component.java:6298)
	at java.awt.Container.processEvent(Container.java:2236)
	at java.awt.Component.dispatchEventImpl(Component.java:4889)
	at java.awt.Container.dispatchEventImpl(Container.java:2294)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4888)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4525)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4466)
	at java.awt.Container.dispatchEventImpl(Container.java:2280)
	at java.awt.Window.dispatchEventImpl(Window.java:2746)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:80)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:90)
	at java.awt.EventQueue$4.run(EventQueue.java:731)
	at java.awt.EventQueue$4.run(EventQueue.java:729)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:80)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

I don't know if this is caused by some recent changes or if it's a problem in the plugin (thus I am reporting it against core)

JOSM:

Build-Date:2017-09-06 15:03:35
Revision:12761
Is-Local-Build:true

Identification: JOSM/1.5 (12761 SVN pt_BR) Linux Debian GNU/Linux testing (buster)
Memory Usage: 1606 MB / 6372 MB (863 MB allocated, but free)
Java version: 1.8.0_144-8u144-b01-1-b01, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1600x900, :0.1 1280x1024
Maximum Screen Size: 1600x1024
Java package: openjdk-8-jre:amd64-8u144-b01-1
Java ATK Wrapper package: libatk-wrapper-java:all-0.33.3-13
VM arguments: [-Dawt.useSystemAAFontSettings=on]
Dataset consistency test: No problems found

Plugins:
+ Create_grid_of_ways (32699)
+ FastDraw (33583)
+ ImportImagePlugin (33563)
+ OpeningHoursEditor (33185)
+ PicLayer (33385)
+ RoadSigns (33579)
+ SimplifyArea (33004)
+ apache-commons (33517)
+ buildings_tools (33004)
+ conflation (0.5.5)
+ contourmerge (1030)
+ download_along (32946)
+ editgpx (33004)
+ ejml (32680)
+ geojson (55)
+ geotools (33380)
+ importvec (33564)
+ indoorhelper (33088)
+ jts (32699)
+ log4j (32699)
+ measurement (33088)
+ merge-overlap (33436)
+ opendata (33553)
+ pbf (33568)
+ pdfimport (33579)
+ poly (33570)
+ reverter (33572)
+ scripting (30771)
+ tageditor (33579)
+ todo (30301)
+ turnlanes (33294)
+ turnlanes-tagging (254)
+ turnrestrictions (33537)
+ undelete (33480)
+ utilsplugin2 (33579)

Attachments (0)

Change History (4)

comment:1 Changed 3 weeks ago by Don-vip

Component: CorePlugin turnlanes-tagging
Owner: changed from team to Don-vip
Status: newassigned

The modularization effort requires sometimes changes in plugins. This is caused by #13036

comment:2 Changed 3 weeks ago by Don-vip

Component: Plugin turnlanes-taggingPlugin tageditor

comment:3 Changed 3 weeks ago by Don-vip

Component: Plugin tageditorCore
Keywords: regression added
Milestone: 17.09

comment:4 Changed 3 weeks ago by Don-vip

Resolution: fixed
Status: assignedclosed

In 12762/josm:

fix #15254 - see #13036 - do not create empty SequenceCommand

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.