Modify

Opened 3 months ago

Closed 8 weeks ago

Last modified 8 weeks ago

#15198 closed defect (fixed)

JOSM freezes after showing popup for unsuccesfull search

Reported by: GerdP Owned by: team
Priority: normal Milestone: 17.09
Component: Core Version:
Keywords: template_report Cc:

Description (last modified by GerdP)

What steps will reproduce the problem?

  1. Load some data
  2. Search for an object that doesn't exist, e.g. highway=xyz
  3. A popoup is shown that nothing was found
  4. Sometimes this popup disappears when I press Enter or Esc, sometimes not. I decided to open a ticket

and while reproducing the problem JOSM decided to freeze.

What is the expected result?

Popup should disappear

What happens instead?

In this particular case JOSM no longer reacts. I cannot close the popup by pressing Enter or Esc or by clicking on the OK button. When I click somewere else I hear a Windows System Sound.
Pressing Alt+F4 also doesn't work.

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-07-31 01:02:55 +0200 (Mon, 31 Jul 2017)
Build-Date:2017-07-31 01:53:17
Revision:12545
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12545 de) Windows 10 64-Bit
OS Build number: Windows 10 Home 1703 (15063)
Memory Usage: 2666 MB / 5461 MB (1344 MB allocated, but free)
Java version: 1.8.0_121-b13, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1080
Maximum Screen Size: 1920x1080
Dataset consistency test: No problems found

Plugins:
+ OpeningHoursEditor (33185)
+ apache-commons (32994)
+ buildings_tools (33004)
+ ejml (32680)
+ geotools (33380)
+ jts (32699)
+ o5m (33243)
+ opendata (33438)
+ pbf (33241)
+ poly (33004)
+ reverter (33088)
+ utilsplugin2 (33328)

Last errors/warnings:
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet

Attachments (4)

visual-vm.txt (26.9 KB) - added by GerdP 3 months ago.
visual vm threaddump
screeshot.jpg (416.6 KB) - added by GerdP 3 months ago.
threaddump.txt (55.0 KB) - added by GerdP 2 months ago.
new thread dump
dump12879.txt (27.5 KB) - added by GerdP 2 months ago.

Download all attachments as: .zip

Change History (17)

Changed 3 months ago by GerdP

Attachment: visual-vm.txt added

visual vm threaddump

Changed 3 months ago by GerdP

Attachment: screeshot.jpg added

comment:1 Changed 3 months ago by GerdP

Description: modified (diff)

comment:2 Changed 2 months ago by GerdP

Happened a few more times now. I have no idea why and I don't know much about GUI programming, so I can't help with a patch :-(

comment:3 Changed 2 months ago by bastiK

Resolution: fixed
Status: newclosed

In 12839/josm:

fixed #15198 - JOSM freezes after showing popup for unsuccesfull search

comment:4 Changed 2 months ago by bastiK

Milestone: 17.09

comment:5 Changed 2 months ago by GerdP

Looks good. No problems during the last two days.

comment:6 Changed 2 months ago by GerdP

Resolution: fixed
Status: closedreopened

Sorry, happened again right now (with r12839).
If I got this right it happens when I do this:
1) Start unsuccesful search
2) Press Alt+Tab to switch to a different Window, e.g. Firefox, press some keys in this app
3) Press Alt+Tab again to switch back to JOSM
4) Press Esc to remove the popup
JOSM no longer reacts.

comment:7 Changed 2 months ago by bastiK

Please add a thread dump for this freeze!

Cannot reproduce on my system (XUbuntu).

Changed 2 months ago by GerdP

Attachment: threaddump.txt added

new thread dump

comment:8 Changed 2 months ago by bastiK

The line numbers in the thread dump do not match the source code. Could you please double check, that you are running version 12839 or later (and not a custom build)?

comment:9 Changed 2 months ago by GerdP

Strange.
JOSM help says version 12839. I compiled it from svn and I don't see any modifications in the java sources.

I've just updated to 12879 and used ant clean dist to compile. I am not able to reproduce the problem with this version
while I was able to reproduce it this morning with the version that said 12839. Maybe I did not use ant clean to compile that buggy version.

Changed 2 months ago by GerdP

Attachment: dump12879.txt added

comment:10 Changed 2 months ago by GerdP

Tried a few more times, now it happened again with 12879.

comment:11 in reply to:  9 Changed 2 months ago by bastiK

Replying to GerdP:

Maybe I did not use ant clean to compile that buggy version.

This seems like a plausible explanation, but apparently it makes no difference.

comment:12 Changed 8 weeks ago by Don-vip

Resolution: fixed
Status: reopenedclosed

I can't reproduce it on Windows. Please update your version of Java and open a new ticket if reproduced.

comment:13 Changed 8 weeks ago by GerdP

See #15375. I was able to reproduce it two times (with two tries)

Last edited 8 weeks ago by GerdP (previous) (diff)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.