Modify

Opened 4 months ago

Closed 4 months ago

Last modified 4 months ago

#15152 closed defect (fixed)

Overpass Download does not take into account bounding box if no query is typed

Reported by: markus_brd@… Owned by: team
Priority: normal Milestone: 17.08
Component: Core Version:
Keywords: overpass download regression Cc: michael2402, bafonins

Description

What steps will reproduce the problem?

  1. When I try to downloat with overpass, then there comes a message "No daga..." and no osm-datas are downloadedd.

But when I use normal downloat, It works without problem.
I also resetted all settings, and tried again, no success.

Can anyone Helpe me here ?

What is the expected result?

No Data loaded

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-08-13 19:54:54 +0200 (Sun, 13 Aug 2017)
Build-Date:2017-08-14 01:35:37
Revision:12598
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12598 de) Mac OS X 10.11.6
OS Build number: Mac OS X 10.11.6 (15G1611)
Memory Usage: 582 MB / 1820 MB (374 MB allocated, but free)
Java version: 1.8.0_144-b01, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: Display 69675840 1920x1200
Maximum Screen Size: 1920x1200
Dataset consistency test: No problems found

Plugins:
+ DxfImport (1010)
+ FixAddresses (33182)
+ ImproveWay (12)
+ austriaaddresshelper (1495805712)
+ auto_tools (1494971731)
+ buildings_tools (33004)
+ contourmerge (1030)
+ ext_tools (33004)
+ merge-overlap (33436)
+ rasterfilters (33269)
+ reltoolbox (33311)
+ reverter (33088)
+ turnrestrictions (33088)
+ utilsplugin2 (33328)

Last errors/warnings:
- W: Ext_Tools warning: can not load file <josm.userdata>/plugins/ext_tools/tools.cfg
- W: Ext_Tools warning: can not load file <josm.userdata>/plugins/ext_tools/repo.cfg

Attachments (0)

Change History (15)

comment:1 Changed 4 months ago by stoecker

Owner: changed from team to markus_brd@…
Status: newneedinfo

There is no error message here, so I assume you have a wrong overpass query (especially output options). Please verify your query with overpass (there is a feature to check the query for JOSM compliance). If still not working, post the query here.

comment:2 Changed 4 months ago by Don-vip

Component: Core bugreportCore
Keywords: download added; Download not working message no data removed

comment:3 Changed 4 months ago by OpenMapMax

I didn´t change the querry Just the message "*add your query below...*"
In older Versions I had no problem to download. (ok the query-wizard is new)

I use overpass because downloading with overpass allowes bigger Region.

So how to create a query to download all available data in selected Region?

thanks

comment:4 Changed 4 months ago by OpenMapMax

OK, in older Versions of JOSM it was possible to just klick on "Download with Overpass-API", select a region and click on Download.

So maybe you can change the query so that when it is leaved blanc, all data is downloaded for selected region ? (because in older Versions of JOSM it was no problem)

comment:5 Changed 4 months ago by Don-vip

Ticket #15156 has been marked as a duplicate of this ticket.

comment:6 Changed 4 months ago by Don-vip

Keywords: regression added
Milestone: 17.08
Owner: changed from markus_brd@… to team
Status: needinfonew
Summary: Overpass Download failsOverpass Download does not take into account bounding box if no query is typed

comment:7 Changed 4 months ago by michael2402

Cc: michael2402 bafonins added

comment:8 Changed 4 months ago by bafonins

I see the problem. The reason no data is loaded is simply because the query is not empty. There is still that comment and it seems that the Overpass server does not recognize that an empty query and a query having only some commented text are equal. But, with the current version of josm removing that comment wont help either, because queries are validated for not being empty. I will fix this tomorrow.

comment:9 Changed 4 months ago by michael2402

Resolution: fixed
Status: newclosed

In 12608/josm:

Fix #15152: Warn on empty overpass query and ask user to download full area instead.

comment:10 in reply to:  8 ; Changed 4 months ago by michael2402

Replying to bafonins:

I see the problem. The reason no data is loaded is simply because the query is not empty. There is still that comment and it seems that the Overpass server does not recognize that an empty query and a query having only some commented text are equal. But, with the current version of josm removing that comment wont help either, because queries are validated for not being empty. I will fix this tomorrow.

Too late ;-) I already did that together with checking your patch for #15057

comment:11 in reply to:  10 Changed 4 months ago by bafonins

Replying to michael2402:

Replying to bafonins:

I see the problem. The reason no data is loaded is simply because the query is not empty. There is still that comment and it seems that the Overpass server does not recognize that an empty query and a query having only some commented text are equal. But, with the current version of josm removing that comment wont help either, because queries are validated for not being empty. I will fix this tomorrow.

Too late ;-) I already did that together with checking your patch for #15057

Thanks! Will check the code later.

comment:12 Changed 4 months ago by OpenMapMax

Thanks, and sorry first i meant it did not work at all.
I take a look at new build now.

I often used this in older versions... so hope it can get as easy.
And new with wizzard is also great. Thanks for the work.

comment:13 Changed 4 months ago by Klumbumbus

When it asks "You entered an empty query. Do you want to download all data in this area instead?" and you click on No, it starts loading anyway and ends with the message "No data found in this area".
This seems a bit strange to me. I would expect that it goes back to the "download via Overpass" window instead of contacting the server.

comment:14 in reply to:  13 ; Changed 4 months ago by michael2402

Replying to Klumbumbus:

When it asks "You entered an empty query. Do you want to download all data in this area instead?" and you click on No, it starts loading anyway and ends with the message "No data found in this area".
This seems a bit strange to me. I would expect that it goes back to the "download via Overpass" window instead of contacting the server.

You are right with that.

Currently, I implemented it like the repair query functionality that overpass turbo provides. It checks for a possibly empty query (regex) and then asks you to repair.

For other repairable queries this might be a good behaviour to say "no, I want the query exactly as it is". For example, we can replace the out calls with out meta calls or change the response type to XML to make the query result loadable by JOSM.

comment:15 in reply to:  14 Changed 4 months ago by Klumbumbus

Replying to michael2402:

For other repairable queries this might be a good behaviour to say "no, I want the query exactly as it is". For example, we can replace the out calls with out meta calls or change the response type to XML to make the query result loadable by JOSM.

OK, that makes sense, however for the special case of an empty query it seems it doesn't make sense as it will never load anything.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.