Modify

Opened 2 months ago

Closed 2 months ago

Last modified 2 months ago

#15144 closed defect (duplicate)

Spurious errors "Coastline inside waterway=riverbank"

Reported by: kennykb Owned by: team
Priority: normal Milestone:
Component: Core validator Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. .osm file for my current data layer is attached
  2. 'Edit->Search...', search for 'waterway=riverbank' and replace current selection.
  3. Click the 'Validation' button.

What is the expected result?

Only the warning for Conor Island (small area called an 'island' not an 'islet')

What happens instead?

Four spurious errors stating 'Coastline inside waterway=riverbank'

Please provide any additional information below. Attach a screenshot if possible.

The objects and the alleged conflicts are:

Waterway         Conflict
========         ========
r2277498         w171258854
r7147691         w147824132
r2271491         w224131448
r2277495         w37890242

The relevant check appears to be data/validator/geometry.mapcss, lines 292-296:

/* #10717, #14535 */
way:closed[natural=coastline] ∈ area[natural=water],
way:closed[natural=coastline] ∈ area[waterway=riverbank] {
  throwError: tr("Coastline inside {1}", "{0.tag}");
}

but I don't see how that would fire on the data in question, since there is no 'natural=coastline' anywhere in the current data layer.

Sorry that I haven't tried to dive deeper and work up a patch. If it were a simple error in the MapCSS, that would be easy, but I really don't have time to dive into the code that's interpreting the MapCSS to see where it's going astray to misidentify these things as coastlines.

To my eye, there's nothing obviously wrong with the multipolygons (JOSM shows all the ways closing), and the conflicting ways are things like county boundaries and power lines. No coastlines anywhere nearby.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-07-30 17:07:42 +0200 (Sun, 30 Jul 2017)
Build-Date:2017-07-30 15:14:00
Revision:12542
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12542 en) Linux Ubuntu 17.04
Memory Usage: 1028 MB / 7122 MB (566 MB allocated, but free)
Java version: 1.8.0_131-8u131-b11-2ubuntu1.17.04.3-b11, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1920x1080
Maximum Screen Size: 1920x1080
Java package: openjdk-8-jre:amd64-8u131-b11-2ubuntu1.17.04.3
Java ATK Wrapper package: libatk-wrapper-java:all-0.33.3-13
Dataset consistency test: No problems found

Plugins:
+ OpeningHoursEditor (33185)
+ PicLayer (33385)
+ apache-commons (32994)
+ ejml (32680)
+ geotools (33380)
+ jts (32699)
+ log4j (32699)
+ opendata (33438)
+ reverter (33088)
+ utilsplugin2 (33328)

Tagging presets:
+ ${HOME}/josm/stateParkPreset.xml

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/TigerReviewedNo&zip=1

Last errors/warnings:
- W: Unsaved changes - <html>The relation has been changed.<br><br>Do you want to save your changes?</html>

Attachments (1)

bug.osm (7.5 MB) - added by kennykb 2 months ago.
Data layer at the time of the spurious error.

Change History (5)

Changed 2 months ago by kennykb

Attachment: bug.osm added

Data layer at the time of the spurious error.

comment:1 Changed 2 months ago by Klumbumbus

Resolution: duplicate
Status: newclosed

Closed as duplicate of #15108.
Thanks for the detailed report. The error is already fixed. It was only in the josm versions 12541-12543. Use the current stable or latest version of josm to get rid of that false positive error.

comment:2 Changed 2 months ago by kennykb

Uhm, 12542 is still the current stable version, but I can confirm that it's no longer failing in 12593.

comment:3 in reply to:  2 Changed 2 months ago by Klumbumbus

Replying to kennykb:

Uhm, 12542 is still the current stable version

You're right. I mixed it up.

comment:4 Changed 2 months ago by Don-vip

Ah, I forgot to update the tested version. r12545 should be the current stable version.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.