Modify

Opened 7 days ago

Closed 7 days ago

#15140 closed defect (duplicate)

Strg+Shift+P gives error

Reported by: walterschloegl@… Owned by: team
Priority: normal Milestone:
Component: Plugin turnrestrictions Version: latest
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. load osm file
  2. mark many objects
  3. press Strg+Shift+P

What is the expected result?

objects should be removed without error

What happens instead?

error

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-07-30 17:07:42 +0200 (Sun, 30 Jul 2017)
Build-Date:2017-07-30 15:14:00
Revision:12542
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12542 de) Windows 7 64-Bit
OS Build number: Windows 7 Home Premium (7601)
Memory Usage: 345 MB / 455 MB (154 MB allocated, but free)
Java version: 1.8.0_73-b02, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1200, \Display1 1280x1024
Maximum Screen Size: 1920x1200
Dataset consistency test: No problems found

Plugins:
+ buildings_tools (33004)
+ turnrestrictions (33088)

Last errors/warnings:
- W: Too many errors. Dropping ReportedException [thread=Thread[AWT-EventQueue-0,6,main], exception=org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive must be part of the dataset: {Node id=2339447034 version=1 V lat=64.4129935,lon=39.4587915}, methodWarningFrom=BugReportExceptionHandler#handleException]
- E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive must be part of the dataset: {Node id=2339447034 version=1 V lat=64.4129935,lon=39.4587915}
- W: Too many errors. Dropping ReportedException [thread=Thread[AWT-EventQueue-0,6,main], exception=org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive must be part of the dataset: {Node id=2339447034 version=1 V lat=64.4129935,lon=39.4587915}, methodWarningFrom=BugReportExceptionHandler#handleException]
- E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive must be part of the dataset: {Node id=2339447027 version=1 V lat=64.4093976,lon=39.4572465}
- E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive must be part of the dataset: {Node id=2339447027 version=1 V lat=64.4093976,lon=39.4572465}
- E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive must be part of the dataset: {Node id=2339447027 version=1 V lat=64.4093976,lon=39.4572465}
- E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive must be part of the dataset: {Node id=2339447027 version=1 V lat=64.4093976,lon=39.4572465}
- E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive must be part of the dataset: {Node id=2339447027 version=1 V lat=64.4093976,lon=39.4572465}
- E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive must be part of the dataset: {Node id=2339447024 version=1 V lat=64.4120024,lon=39.463259}
- E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive must be part of the dataset: {Node id=2339447024 version=1 V lat=64.4120024,lon=39.463259}


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (20) of main
org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive must be part of the dataset: {Node id=2339447060 version=1 V lat=64.4109366,lon=39.4609845}
	at org.openstreetmap.josm.data.osm.OsmPrimitive.checkDataset(OsmPrimitive.java:252)
	at org.openstreetmap.josm.data.osm.OsmPrimitive.getReferrers(OsmPrimitive.java:996)
	at org.openstreetmap.josm.data.osm.OsmPrimitive.getReferrers(OsmPrimitive.java:1021)
	at org.openstreetmap.josm.plugins.turnrestrictions.list.TurnRestrictionsInSelectionListModel.initFromSelection(TurnRestrictionsInSelectionListModel.java:40)
	at org.openstreetmap.josm.plugins.turnrestrictions.list.TurnRestrictionsInSelectionListModel.selectionChanged(TurnRestrictionsInSelectionListModel.java:66)
	at org.openstreetmap.josm.data.osm.event.SelectionEventManager$OldListenerInfo.fire(SelectionEventManager.java:57)
	at org.openstreetmap.josm.data.osm.event.SelectionEventManager.fireEvent(SelectionEventManager.java:203)
	at org.openstreetmap.josm.data.osm.event.SelectionEventManager.lambda$selectionChanged$0(SelectionEventManager.java:198)
	at java.awt.event.InvocationEvent.dispatch(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (1)

comment:1 Changed 7 days ago by Klumbumbus

Component: CorePlugin turnrestrictions
Resolution: duplicate
Status: newclosed

Closed as duplicate of #15008.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.