Modify

Opened 8 days ago

Closed 8 days ago

#15137 closed defect (duplicate)

DataIntegrityProblemException after purging objects

Reported by: naoliv Owned by: team
Priority: normal Milestone:
Component: Plugin turnrestrictions Version:
Keywords: Cc: michael2402

Description

Open https://www.openstreetmap.org/#map=19/37.76366/-122.47627 in JOSM, Ctrl+A to select everything, Edit → Purge

After a while the console is flooded with a lot of messages like this:

2017-08-11 14:54:02.248 WARNING: Too many errors. Dropping ReportedException [thread=Thread[AWT-EventQueue-0,6,main], exception=org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive must be part of the dataset: {Node id=2731366525 version=1 V lat=37.7640224,lon=-122.4751581}, methodWarningFrom=BugReportExceptionHandler#handleException]
^C2017-08-11 14:54:02.301 SEVERE: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive must be part of the dataset: {Node id=2731366525 version=1 V lat=37.7640224,lon=-122.4751581}
org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive must be part of the dataset: {Node id=2731366525 version=1 V lat=37.7640224,lon=-122.4751581}
	at org.openstreetmap.josm.data.osm.OsmPrimitive.checkDataset(OsmPrimitive.java:252)
	at org.openstreetmap.josm.data.osm.OsmPrimitive.getReferrers(OsmPrimitive.java:996)
	at org.openstreetmap.josm.data.osm.OsmPrimitive.getReferrers(OsmPrimitive.java:1021)
	at org.openstreetmap.josm.plugins.turnrestrictions.list.TurnRestrictionsInSelectionListModel.initFromSelection(TurnRestrictionsInSelectionListModel.java:40)
	at org.openstreetmap.josm.plugins.turnrestrictions.list.TurnRestrictionsInSelectionListModel.selectionChanged(TurnRestrictionsInSelectionListModel.java:66)
	at org.openstreetmap.josm.data.osm.event.SelectionEventManager$OldListenerInfo.fire(SelectionEventManager.java:57)
	at org.openstreetmap.josm.data.osm.event.SelectionEventManager.fireEvent(SelectionEventManager.java:203)
	at org.openstreetmap.josm.data.osm.event.SelectionEventManager.lambda$selectionChanged$0(SelectionEventManager.java:198)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:311)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:756)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:80)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:726)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

JOSM:

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-08-11 18:46:40 +0200 (Fri, 11 Aug 2017)
Build-Date:2017-08-11 17:28:16
Revision:12591
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12591 pt_BR) Linux Debian GNU/Linux testing (buster)
Memory Usage: 849 MB / 9102 MB (506 MB allocated, but free)
Java version: 1.8.0_141-8u141-b15-3-b15, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1600x900, :0.1 1280x1024
Maximum Screen Size: 1600x1024
Java package: openjdk-8-jre:amd64-8u141-b15-3
Java ATK Wrapper package: libatk-wrapper-java:all-0.33.3-13
VM arguments: [-Dawt.useSystemAAFontSettings=on]

Plugins:
+ Create_grid_of_ways (32699)
+ FastDraw (33182)
+ ImportImagePlugin (33372)
+ OpeningHoursEditor (33185)
+ PicLayer (33385)
+ RoadSigns (33204)
+ SimplifyArea (33004)
+ apache-commons (32994)
+ buildings_tools (33004)
+ conflation (0.5.4)
+ contourmerge (1030)
+ download_along (32946)
+ editgpx (33004)
+ ejml (32680)
+ geojson (52)
+ geotools (33380)
+ importvec (33088)
+ indoorhelper (33088)
+ jts (32699)
+ log4j (32699)
+ measurement (33088)
+ merge-overlap (33436)
+ opendata (33438)
+ pbf (33241)
+ pdfimport (33004)
+ poly (33004)
+ reverter (33088)
+ scripting (30768)
+ tageditor (33021)
+ todo (30200)
+ turnlanes (33294)
+ turnlanes-tagging (254)
+ turnrestrictions (33088)
+ undelete (33480)
+ utilsplugin2 (33328)

Attachments (0)

Change History (3)

comment:1 Changed 8 days ago by naoliv

My guess: maybe it should start purging the nodes, then ways and then the relations? (the same logic for uploading objects)

comment:2 Changed 8 days ago by stoecker

Cc: michael2402 added
Component: CorePlugin turnrestrictions

Looks more like turnrestrictions plugin does not refresh. Probably related to the chnages to notifications.

comment:3 Changed 8 days ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #15008.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.