Modify

Opened 9 days ago

Closed 9 days ago

#15132 closed defect (duplicate)

All islands [landuse=*] inside [natural=water] mapped as multipolygon are considered as ERROR by JOSM validation: 'Coastline inside natural=water'

Reported by: AnkEric Owned by: team
Priority: normal Milestone:
Component: Core validator Version: latest
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

JOSM Validation on:
multipolygon ("water"): 2-members
outer way = [natural=water]
inner way = [landuse=*] (which is an "island")

JOSM validation:
Error: "Coastline inside natural=water"

Error is new to JOSM v.12542.

What is the expected result?

This is no Error.
IMO: multipolygon is correct.
Or: ALL islands have been mapped incorrectly (meaning thousands).

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-07-30 17:07:42 +0200 (Sun, 30 Jul 2017)
Build-Date:2017-07-30 15:14:00
Revision:12542
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12542 en) Windows 10 64-Bit
OS Build number: Windows 10 Home 1703 (15063)
Memory Usage: 531 MB / 910 MB (235 MB allocated, but free)
Java version: 1.8.0_141-b15, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1080
Maximum Screen Size: 1920x1080
Dataset consistency test: No problems found

Plugins:
+ Mapillary (v1.5.5)
+ OpeningHoursEditor (33185)
+ apache-commons (32994)
+ apache-http (32699)
+ contourmerge (1030)
+ reverter (33088)
+ routes (33292)
+ turnrestrictions (33088)
+ utilsplugin2 (33328)

Tagging presets:
+ <josm.pref>\presets\NL_fiets_preset.xml
+ <josm.pref>\presets\Picnic_table.xml

Last errors/warnings:
- E: Failed to locate image 'presets/bike.png'
- W:  Fietspaden: Could not get presets icon presets/bike.png
- W: java.net.SocketTimeoutException: Read timed out

Attachments (0)

Change History (1)

comment:1 Changed 9 days ago by Klumbumbus

Component: CoreCore validator
Resolution: duplicate
Status: newclosed

Closed as duplicate of #15108.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.